Known issues
Third-party programs
If you have installed a third-party program that registers the Microsoft.Crm.MetadataService.dll file to the global assembly cache (GAC), you may experience a problem in Microsoft Dynamics CRM after you install this update rollup. You may experience this problem if you save an entity or an attribute, or if you update an entity or an attribute.
For more information about how to resolve this problem, click the following article number to view the article in the Microsoft Knowledge Base:
934690 Error message when you save or update an entity or an attribute in Microsoft Dynamics CRM 3.0: "An error has occurred. For more information, contact your system administrator"
Export and import of customizations
If customizations are exported from a Microsoft Dynamics CRM server that has an update rollup installed, you cannot import the customizations to a Microsoft Dynamics CRM server that does not have the same update rollup installed. If you try to import customizations in this manner, you receive the following error message:
The selected schema file does not conform with the requested format. There has been an error with the schema validation in line 37977, position 16.
Therefore, you must verify that both servers have the same update rollup installed when you transfer customizations between two servers.
Delete the temporary Internet files
You may have to delete the temporary Internet files after you apply the fixes. To do this, follow these steps:
- Start Windows Internet Explorer.
- On the Tools menu, click Internet Options, and then click Delete Files.
Error messages
Error message 1
Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base: 322756 How to back up and restore the registry in Windows
When you install Update Rollup 2 for Microsoft Dynamics CRM 3.0, you may receive the following error message:
Application has generated an exception that could not be handled. Process id 0x4f4 (1268), Thread Id=0xe7c (3708).
This problem is related to the daylight saving time update that is included together with Update Rollup 2. This problem occurs for one of the following reasons.
Cause 1
A registry key is missing. This registry key is required by the TimeZoneUpdatePatch.exe file. The TimeZoneUpdatePatch.exe file runs as a subprocess of the Update Rollup 2 installation. See Resolution 1 later in this section.
Cause 2
An unknown registry key is queried by the TimeZoneUpdatePatch.exe file. The TimeZoneUpdatePatch.exe file runs as a subprocess of the Update Rollup 2 installation. See Resolution 2 later in this section.
Note Time zones are stored in the registry in the following location:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Time Zones
Resolution 1
- Copy the time zone registry key values to a text file. To do this, type the following command in a Command Prompt window.
REG QUERY "HKLM\Software\Microsoft\Windows NT\CurrentVersion\Time Zones" /s | findstr /I "index software Dlt Std Display TZI" >TimeZoneRegInfo.txt
- Use the same command on another Microsoft Dynamics CRM Server on which Update Rollup 2 was successfully installed.
- Install the Windiff.exe file. To do this, use one of the following methods.
Installation from Windows version CD
- Insert the Windows version CD-ROM into your drive.
- Click Browse this CD, and then open the Support\Tools folder.
- Double-click Setup.exe, and then follow the instructions that appear on the screen.
Installation from Microsoft Download Center
For Windows XP Service Pack 2, visit the following MIcrosoft Web site: For Windows Server 2003 Service Pack 1, visit the following Microsoft Web site: - To compare the TimeZoneRegInfo.txt files, run the Windiff utility.
- Compare the TimeZoneRegInfo.txt files to determine which time zones are missing an index entry for a specific time zone. Time zones that are missing an index entry have a value of DWORD. Next, open the registry, and then type the correct value. To open the registry, click Start, click Run, and then type regedit.
Resolution 2
- Copy the time zone registry key values to a text file. To do this, type the following command in a Command Prompt window.
REG QUERY "HKLM\Software\Microsoft\Windows NT\CurrentVersion\Time Zones" /s | findstr /I "index software Dlt Std Display TZI" >TimeZoneRegInfo.txt
- Use the same command on another Microsoft Dynamics CRM Server on which Update Rollup 2 was successfully installed.
- Download the Windiff.exe file. To do this, visit the following Microsoft Web site:
- To compare the TimeZoneRegInfo.txt files, run the Windiff utility.
- In the TimeZoneRegInfo.txt file for the Microsoft Dynamics CRM server on which Update Rollup 2 was successfully installed, look for time zones that are unknown. For example, the following registry key prevents Update Rollup 2 from being installed successfully:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Time Zones\Jerusalem Standard Time
- Export the unknown time zone registry key to create a backup. To do this, select the registry key, click File, and then click Export. Save the registry key as an .reg file.
- Start the setup of Update Rollup 2 again.
- When Update Rollup 2 is successfully installed, enter the unknown time zone registry key in the registry. To do this, double-click the file that you created in step 6 earlier in this section.
Error message 2
When you install Update Rollup 2 on the Microsoft Dynamics CRM server, you may receive the following error message:
Setup failed to update the database. The installation of this update has stopped. Contact customer support services.
Or, the installation log file may contain the following error message:
(Error) DB update Initialization failed with code 64541. Function: CCompActionBase::ValidateDBUpdateInstall File: c:\bt\716\src\crmse\installer\mscrmcustom\ccompactionbase.cpp Line: 758
Cause
This problem occurs because the Data Migration Framework is installed.
Resolution
To resolve this problem, follow these steps:
- Click Start, click Control Panel, and then double-click Add or Remove Programs.
- In the Add or Remove Programs dialog box, click to select the Microsoft Dynamics CRM Data Migration Framework check box.
- Click Remove.
Error message 3
When you try to install Update Rollup 2, you receive the following error message:
Setup failed to update the database. The installation of this update has stopped. Contact Customer Support Services.
Additionally, the following information is logged in the KB927751_err.log file on the Microsoft Dynamics CRM server:
Note This log file is in the %windir% folder. Usually, this folder is the C:\Windows folder.
Cause 1
This problem usually occurs because a large number of contacts are being updated by hotfix 923057. Hotfix 923057 is included in Update Rollup 2 for Microsoft Dynamics CRM 3.0.
Cause 2
This problem usually occurs if the following conditions are true:
- The system was upgraded from Microsoft CRM 1.2 to Microsoft Dynamics CRM 3.0.
- Custom fields were created in Microsoft Dynamics CRM 3.0 for noncustom task activity fields of a certain type in Microsoft CRM 1.2.
The presence of these fields prevents hotfix 913954 from being installed. Hotfix 913954 is included in Update Rollup 2 for Microsoft Dynamics CRM 3.0.
Resolution 1
Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base: 322756 How to back up and restore the registry in Windows
To resolve this problem, increase the DWORD value for the HotfixDBTimeout registry entry. This registry entry is located in the following registry subkey:
HKEY_LOCAL_MACHINE\Software\Microsoft\MSCRM
The value that you set for the DWORD value depends on the number of contacts in the Microsoft Dynamics CRM database. However, do not set the value higher than a decimal value of 65535 because Update Rollup 2 does not recognize decimal values above 65535. To change the DWORD value of the HotfixDBTimeout registry entry, follow these steps:
- On the Microsoft Dynamics CRM server, click Start, click Run, type regedit, and then click OK.
- Click the following registry subkey:
HKEY_LOCAL_MACHINE\Software\Microsoft\MSCRM
If the HotfixDBTimeout registry entry does not exist, go to step 3. If the HotfixDBTimeout registry entry already exists, go to step 5. - On the Edit menu, point to New, and then click DWORD Value.
- Type HotfixDBTimeout, and then press ENTER.
- Right-click HotfixDBTimeout, and then click Modify.
- Click Decimal base, type 65000 in the Value data box, and then click OK.
Note Hotfix installations only recognize decimal values between 0 and 65535. The value indicates the seconds the program will wait for a response to a query before you receive the error message. You can leave this value after you successfully install Update Rollup 2. - On the File menu, click Exit to exit Registry Editor.
If you continue to receive the error message after you follow the steps to change the DWORD value of the HotfixDBTimeout registry entry, you may have to add or modify the DWORD value of the OLEDBTimeout registry entry. This registry entry is located in the following registry subkey:
HKEY_LOCAL_MACHINE\Software\MSCRM
To do this, follow these steps:
- On the Microsoft Dynamics CRM server, click Start, click Run, type regedit, and then click OK.
- Click the following registry subkey:
HKEY_LOCAL_MACHINE\Software\Microsoft\MSCRM
If the OLEDBTimeout registry entry does not exist, go to step 3. If the OLEDBTimeout registry entry already exists, go to step 5. - On the Edit menu, point to New, and then click DWORD Value.
- Type OLEDBTimeout, and then press ENTER.
- Right-click OLEDBTimeout, and then click Modify.
- Click Decimal base, type 65000 in the Value data box, and then click OK.
Note The value indicates the seconds the program will wait for a response to a query before you receive the error message. If the DWORD value of the OLEDBTimeout registry entry is not configured, the default timeout is 30 seconds. - On the File menu, click Exit to exit Registry Editor.
- Install Update Rollup 2 for Microsoft Dynamics CRM again on the Microsoft Dynamics CRM server.
- Change the value of the OLEDBTimeout registry entry back to a value that is between 30 and 300.
Note After you successfully install Update Rollup 2, we recommend that you change the value of this registry entry back to a decimal value between 30 and 300. This helps prevent performance problems because larger values allow long-running Microsoft SQL Server queries from Microsoft Dynamics CRM to continue without timing out. Long-running SQL Server queries may cause SQL Server to block other queries from running.
Resolution 2
To resolve this problem, delete the attributes, if they do not hold any values. To do this, follow these steps:
- Back up the MSCRM and Metabase database.
- Start Microsoft Dynamics CRM, click Customizations, click Task, and then click Attributes.
- Delete the following attributes:
- CFIDirectionCode
- CFIScheduledDurationMinutes
- CFIStatusCode
- CFDScheduledEnd
- Click Save, and then click Publish to delete the attributes from the Task entity.
- Try to install Update Rollup 2 for Microsoft Dynamics CRM.