Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

PRB: MDAC Installation on Windows Terminal Server May Fail


View products that this article applies to.

Symptoms

If you install Microsoft Data Access Components (MDAC) version 2.1, 2.5, or 2.6 on Windows NT 4.0 Terminal Server or Windows 2000 Terminal Services, sometimes the MDAC installation may fail.

This problem may also occur after you use Component Checker to reconfigure the MDAC installation on Terminal Server.

↑ Back to the top


Cause

This problem occurs when a registry setting that points to the Program Files\Common Files folder is overwritten with the incorrect entry.

↑ Back to the top


Resolution

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

  1. From the Start menu, click Run, type Regedt32.exe, and then click OK to open Registry Editor.
  2. Change the following registry key to point to your Program Files\Common Files folder:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion
  3. Quit Registry Editor.

↑ Back to the top


References

For additional information about installing MDAC on Terminal Server, click the article numbers below to view the articles in the Microsoft Knowledge Base:
216149 How to Install ODBC or MDAC on Terminal Server
304332 PRB: Installing MDAC on Terminal Server
For general information regarding MDAC installation, see the following Microsoft Web site:

↑ Back to the top


Keywords: KB305838, kbprb

↑ Back to the top

Article Info
Article ID : 305838
Revision : 6
Created on : 11/3/2003
Published on : 11/3/2003
Exists online : False
Views : 415