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You receive an "I/O Error" or the subfolders are displayed as question marks or squares in Office programs


View products that this article applies to.

Symptoms

When you click Open, Save, or Save As on the File menu in any of the Microsoft Office programs listed at the beginning of this article, you may experience one of the following symptoms:
  • When the current folder has subfolders, all subfolders except the last may be displayed as question marks or squares.
  • If you double-click any of the subfolders that appear as question marks or squares, or if you try to open a presentation, you may receive one of the following error messages:
    • An unexpected error occurred - I/O Error 0
      - or -
    • An unexpected error occurred - I/O Error 6
      - or -
    • <Program> found an error it cannot correct.
      where <Program> is the name of one of the programs listed at the beginning of this article.
    NOTE: You can open files correctly if you select them from the Most Recently Used (MRU) list on the File menu, or if you double-click the file in Windows Explorer.
Also, when you attempt to start Microsoft PowerPoint, you receive the following error message:
PowerPoint found an error it cannot correct.

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Cause

The Microsoft Office settings stored in the registry are damaged (corrupted).

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Resolution

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows


To correct this problem, use one of the following methods as appropriate for your situation.

Method 1: Delete the HKEY_CURRENT_USER\Software\Microsoft\Office\X.0 Key

To remove the damaged Office registry settings and to register Office again, follow these steps:

NOTE: The following steps remove all user-specific settings for all of the Office programs. You must reconfigure all user-specific settings manually.
  1. Quit all Office programs.
  2. Click Start, click Run, type regedit, and then click OK.
  3. Locate and then click to select one of the following registry keys, depending on the version of Office that you are using:
    • For Microsoft Office XP, locate and then click to select the following key:
      HKEY_CURRENT_USER\Software\Microsoft\Office\10.0
    • For Microsoft Office 2000, locate and then click to select the following key:
      HKEY_CURRENT_USER\Software\Microsoft\Office\9.0
    • For Microsoft Office 97, locate and then click to select the following key:
      HKEY_CURRENT_USER\Software\Microsoft\Office\8.0
  4. After you select the key that is specified in step 3, point to Delete on the Edit menu. Click Yes when you receive the following message:
    Are you sure you want to delete this key and all of its subkeys?
  5. On the File menu, click Exit to quit Registry Editor.
  6. Shut down and then restart Windows.
  7. Start an Office program to update the registry settings.

Method 2: Reset the Open Dialog Box Settings

To reset the Open dialog box, follow these steps:
  1. Quit all Office programs.
  2. Click Start, click Run, type regedit, and then click OK.
  3. Locate and then click to select one of the following registry keys, depending on the version of Office that you are using:
    • For Office XP, locate and then click to select the following key:
      HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Common\Open Find
    • For Office 2000, locate and then click to select the following key:
      HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common\Open Find
    • For Office 97, locate and then click to select the following key:
      HKEY_CURRENT_USER\Software\Microsoft\Office\8.0\Common\Open Find
  4. After you select the key that is specified in step 3, point to Delete on the Edit menu. Click Yes when you receive the following message:
    Are you sure you want to delete this key and all of its subkeys?
  5. On the File menu, click Exit to quit Registry Editor.
  6. Shut down and then restart Windows.
  7. Start an Office program to update the registry settings.

Method 3: Delete the HKEY_LOCAL_MACHINE\Software\Microsoft\Office\X.0 Key

To remove the damaged Office registry settings and to register Office again, follow these steps.

NOTE: The following steps remove all user-specific settings for all of the Office programs. You must reconfigure all user-specific settings manually.
  1. Quit all Office programs.
  2. Click Start, click Run, type regedit, and then click OK.
  3. Locate and then click to select one of the following registry keys, depending on the version of Office that you are using:
    • For Office XP, locate and then click to select the following key:
      HKEY_LOCAL_MACHINE\Software\Microsoft\Office\10.0
    • For Office 2000, locate and then click to select the following key:
      HKEY_LOCAL_MACHINE\Software\Microsoft\Office\9.0
    • For Office 97, locate and then click to select the following key:
      HKEY_LOCAL_MACHINE\Software\Microsoft\Office\8.0
  4. After you select the key that is specified in step 3, point to Delete on the Edit menu. Click Yes on the message
    Are you sure you want to delete this key and all of its subkeys?
  5. On the File menu, click Exit to quit Registry Editor.
  6. Shut down and then restart Windows.
  7. Start an Office program to update the registry settings.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kbopenfile, kbsavefile, kbtshoot, kbprb, kberrmsg, kbpending, kbusage, KB236872

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Article Info
Article ID : 236872
Revision : 8
Created on : 1/24/2007
Published on : 1/24/2007
Exists online : False
Views : 540