Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Exchange Calendar items are shifted incorrectly when some Windows DST updates are applied


View products that this article applies to.

Symptoms

After the latest daylight saving time (DST) update (3039024) is installed in a Microsoft Exchange Server 2013 or Microsoft Exchange Server 2010 environment, the calendar items may be shifted by one hour in the Calendar view.

↑ Back to the top


Cause

This issue occurs because some time zone properties are truncated when they are passed from Windows to Exchange. However, Exchange cannot parse the truncated properties into a valid time zone. Therefore, Exchange uses the old time zone for the Calendar view.

↑ Back to the top


Resolution

To fix this issue, install one of the following updates on your corresponding server that is running Exchanger Server, as appropriate: 
Note For existing calendar appointments that are incorrect, the calendaring tool must be run to correct these appointments.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: kbtshoot, kbprb, kbsurveynew, kbexpertiseadvanced, kb

↑ Back to the top

Article Info
Article ID : 3048372
Revision : 1
Created on : 1/7/2017
Published on : 12/15/2015
Exists online : False
Views : 292