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OFF2000: "Internal Error 2352" Error Message When You Attempt to Install Office


View products that this article applies to.

This article was previously published under Q299775
WARNING:This information is preliminary and has not been confirmed or tested by Microsoft. Use only with discretion.

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Symptoms

When you attempt to install Microsoft Office 2000 or any Office 2000 program, you may receive one of the following error messages:
Internal error: 2352 Couldn't initialize cabinet file server.
The required file 'Cabinet.dll' may be missing.
-or-
Internal error 2352. Please contact Product support

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Cause

This behavior can occur if the Cabinet.dll file is missing or damaged.

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Resolution

To resolve this issue, install or replace the cabinet file. To do this, follow these steps:
  1. Click Start, point to Find, and then click Files or folders.
  2. In the Named box, type Cabinet.dll, and then click Search Now.
  3. Right-click Cabinet.dll, click Rename, and then type cabinet.old.
  4. Click Start, and then click Run.
  5. In the Open box, type msconfig, and then click OK.
  6. On the General tab, click Selective Startup.
  7. Click to clear each check box under Selective Startup, and then click OK.
  8. Restart your computer.
  9. Insert your Office 2000 CD-ROM, and then browse to the MSI folder on this CD-ROM.
  10. Double-click instmsi.exe.
  11. When instmsi.exe has finished running, click Start, point to Settings and then click Control Panel.
  12. Double-click Add/Remove Programs.
  13. On the Install/Uninstall tab, click Install to install Office 2000 (or the Office program that you want to install).
  14. When the installation is finished, insert your Microsoft Windows CD-ROM to restore the Cabinet.dll file. To extract the Cabinet.dll file from the Windows CD-ROM, use one of the following sets of steps as appropriate to your operating system.

    Windows 98

    1. Click Start, and then click Run.
    2. In the Open box, type sfc, and then click OK.
    3. Click Extract one file from installation disk.
    4. In the Specify the system file you would like to restore box, type Cabinet.dll, and then click Start.
    5. In the Restore from box, type drive:win98, where drive is the letter of your computer's CD-ROM or DVD-ROM drive.
    6. In the Save file in box, type C:\windows\system, and then click OK.
    7. Click OK in the message box.
    8. Click OK when the file has been successfully extracted.For additional information about how to use System File Checker to extract a file, click the article number below to view the article in the Microsoft Knowledge Base:
      129605� How to Extract Original Compressed Windows Files

    Microsoft Windows Millennium Edition (Me)

    1. Click Start, and then click Run.
    2. In the Open box, type msconfig, and then click OK.
    3. Click Extract File.
    4. In the Specify the system file you would like to restore box, type Cabinet.dll, and then click Start.
    5. In the Restore From box, type the path to your Windows Cab files.

      (For example, type C:\Windows\Options\Install, or drive:win9X, where drive is the letter of your computer's CD-ROM or DVD-ROM drive.)
    6. In the Save file in box, type C:\windows\system, and then click OK.
    7. Click OK and continue with the restore function.
  15. Restore normal startup by using the MSConfig utility:
    1. Click Start, and then click Run.
    2. In the Open box, type msconfig, and then click OK.
    3. Click the General tab, and then click Normal startup.
    4. Click OK, and then click Yes on the message to restart your computer.

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Keywords: kberrmsg, kbprb, KB299775

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Article Info
Article ID : 299775
Revision : 7
Created on : 1/31/2007
Published on : 1/31/2007
Exists online : False
Views : 539