Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A presentation does not display or function correctly when you publish it by using a Web publishing application in PowerPoint


View products that this article applies to.

Symptoms

You save a Microsoft PowerPoint presentation as HTML. After you do this, the presentation may not display or function correctly when you publish it by using a Web publishing application.

HTML that is generated by Microsoft Word, by Microsoft Excel, and by Microsoft Publisher may also not display or function correctly when you use a Web publishing application.

↑ Back to the top


Cause

This issue may occur when the XML code that is included in the PowerPoint HTML is not supported by the Web publishing application. Additionally, some Web publishing applications expect all the HTML files to be published in the same folder. These applications do not support a subfolder structure.

You may experience this issue in Word, in Excel, and in Publisher also. These products use a similar output mechanism for HTML.

↑ Back to the top


Workaround

To work around this issue, change the options so that the files are stored in a single location and not in subfolders. There are different workarounds for the different versions of the products. More than one method might apply to your version. Choose the method that works best for you.

Method 1: Save supporting files in the same folder as a Web page

By default, when you save a Web page to a Web server, Excel and Word store all supporting files, such as bullets, background textures, and graphics, in a separate subfolder. If you want to save supporting files in the same folder as the Web page, follow these steps.

Excel 2000, Excel 2002, Excel 2003, Word 2000, Word 2002, and Word 2003

  1. On the Tools menu, click Options, and then click the General tab.
  2. Click Web Options, and then click the Files tab.
  3. Click to clear the Organize supporting files in a folder check box.
Note This option applies to the current page and to any future pages that you save.

PowerPoint 2000, PowerPoint 2002, and PowerPoint 2003

  1. Open the presentation in PowerPoint.
  2. On the File menu, click Save as Web Page, and then click Publish.
  3. In the Browser Support section, click to select the Microsoft Internet Explorer 3.0, Netscape Navigator 3.0, or later check box.
  4. Click Web Options, click the Files tab, click to clear the Organize supporting files in a folder check box, and then click OK.
  5. Click Publish. A set of files is created that has one main index file. This main index file is named Hname.html. Another file that is named Xname.xml is also created, but it does not cause any problems.

    Note Hname and Xname are placeholders for the names of the .html file and the .xml file that are created.

Publisher 2000

On the File menu, click Save as Web Page.

Method 2: Save supporting files as a Web archive

A Web archive saves all the elements of a Web site into a single file. These elements include text and graphics. To do this, follow these steps.

Excel 2002, PowerPoint 2002, Publisher 2002, and Word 2002

  1. On the File menu, click Save As.
  2. In the Save as type list, select Web Archive, and then click OK.

Method 3: Save supporting files as a single file Web page

Excel 2003, PowerPoint 2003, Publisher 2003, and Word 2003

A single file Web page saves all the elements of a Web site into a single file. These elements include text and graphics. To do this, follow these steps:
  1. On the File Menu, click Save As.
  2. In the Save as type list, select Single File Web Page, and then click OK.

↑ Back to the top


Keywords: kbtshoot, kbprb, KB918650

↑ Back to the top

Article Info
Article ID : 918650
Revision : 3
Created on : 5/10/2006
Published on : 5/10/2006
Exists online : False
Views : 392