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You may receive an out-of-memory error message, Event ID 7031 or Event ID 5410 messages, or Event ID 4786 error messages, or you may experience similar symptoms in BizTalk Server


View products that this article applies to.

Symptoms

In Microsoft BizTalk Server 2006, the BizTalk Server process may close unexpectedly. Additionally, you may receive an out-of-memory error message.

In Microsoft BizTalk Server 2004, the BizTalk Server process may restart unexpectedly. Additionally, a message that resembles one of the following may be logged in the Event log:

Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7031
Description: The BizTalk Service BizTalk Group: BizTalkServerApplication service terminated unexpectedly. It has done this 1 time(s). The following corrective action will be taken in 60000 milliseconds: Restart the service.

Event Type: Warning
Event Source: BizTalk Server 2004
Event Category: BizTalk Server 2004
Event ID: 5410
Description: An error has occurred that requires the BizTalk service to terminate. The most common causes are an unexpected out of memory error and an inability to connect or a loss of connectivity to one of the BizTalk databases. The service will shutdown and auto-restart in 1 minute. If the problematic database remains unavailable, this cycle will repeat.

In Microsoft BizTalk Server 2002, the Mscis.exe process may stop responding. Additionally, an error message that resembles the following may be logged in the Application event log:

Event Type: Error
Event Source: COM+
Event Category: Unknown
Event ID: 4786
Description:
The system has called a custom component and that component has failed and generated an exception. This indicates a problem with the custom component. Notify the developer of this component that a failure has occurred and provide them with the information below. 
Component Prog ID: 
Server Application ID: {6ECD95AC-3C06-4A9B-9D43-4565C1BD3319}
Server Application Instance ID:
{2D431C49-FF0C-4E72-A79C-EA07D92F9EF0}
Server Application Name: BizTalk Server Internal Utilities
Exception: C0000005
Address: 0x77BD8DC8
Call Stack: 
msvcrt!wcscpy + 0xe
mytilus!GetDatAndEngineInfo + 0x91a0
mytilus!GetDatAndEngineInfo + 0x3526
scriptproxy!DllGetClassObject + 0x7dc
scriptproxy!DllGetClassObject + 0xccf
msxml3!DllCanUnloadNow + 0x2174d
msxml3!DllCanUnloadNow + 0x2171f
msxml3!DllUnregisterServer + 0x35f5e
msxml3!DllCanUnloadNow + 0x290f
msxml3!DllCanUnloadNow + 0x2f69
msxml3!DllCanUnloadNow + 0x2ea3
msxml3!DllCanUnloadNow + 0x1c0d
msxml3!DllCanUnloadNow + 0x1c6a
msxml3!DllCanUnloadNow + 0x102fc
ciscore!LoadGlobalSettings(void) + 0x8237
CISENGINE!GetNewStateEngine(struct IInterchangeStateEngine * *) + 0x287f
CISENGINE!LKRhash::CLKRHashTable::End(void) + 0x41a4
CISENGINE!GetNewStateEngine(struct IInterchangeStateEngine * *) + 0x1021
CISENGINE!GetNewStateEngine(struct IInterchangeStateEngine * *) + 0xbe0
CISENGINE!GetNewStateEngine(struct IInterchangeStateEngine * *) + 0x499
CISENGINE!GetNewStateEngine(struct IInterchangeStateEngine * *) + 0x6ee
CISENGINE!LKRhash::CLKRHashTable::End(void) + 0x5caa
ole32!ComPs_NdrDllGetClassObject + 0x6db
ole32!CoQueryAuthenticationServices + 0x2dad
ole32!CoQueryAuthenticationServices + 0x30e5
ole32!CoQueryAuthenticationServices + 0x4b84
ole32!CoGetInterceptorFromTypeInfo + 0xc62
ole32!CoGetInterceptorFromTypeInfo + 0xb77
MSCIS!SchedulerRunning(void) + 0x105e
kernel32!GetModuleFileNameA + 0xeb 
Additionally, you may experience similar symptoms in Microsoft BizTalk Server 2000.

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Cause

This issue can occur if all the following conditions are true:
  • Network Associates McAfee VirusScan is installed and enabled on the computer.
  • McAfee VirusScan is configured to scan the BizTalk Server process.

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Resolution

To resolve this issue, contact Network Associates for instructions on how to configure McAfee VirusScan so that McAfee VirusScan does not scan the BizTalk Server process.

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Workaround

Warning This workaround may make your computer or your network more vulnerable to attack by malicious users or by malicious software such as viruses. We do not recommend this workaround but are providing this information so that you can implement this workaround at your own discretion. Use this workaround at your own risk.

To work around this issue, disable McAfee ScriptScan. To disable McAfee ScriptScan, use either of the following methods.

Method 1: Disable McAfee ScriptScan in the McAfee Configuration Console

To work around this issue, disable McAfee ScriptScan in the McAfee Configuration Console.

Method 2: Unregister the Scriptproxy.dll file

To work around this issue, unregister the Scriptproxy.dll file. To do this, follow these steps:
  1. Click Start, click Run, type cmd, and then click OK.
  2. At the Command Prompt window, use the cd command to change to the %ProgramFiles%\Network Associates\VirusScan folder.
  3. At the Command Prompt window, type regsvr32 /u scriptproxy.dll, and then press ENTER.
  4. Restart the computer.

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More information

For information about your hardware manufacturer, visit the following Web site:Note We cannot guarantee the performance and stability of third-party modules or programs. Therefore, we do not support the injection of any third-party module into a process. For more information about how to configure a third-party module or program, contact the manufacturer.

Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

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Keywords: kbantivirus, kbbts, kbtshoot, kbprb, KB917848

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Article Info
Article ID : 917848
Revision : 4
Created on : 5/8/2006
Published on : 5/8/2006
Exists online : False
Views : 610