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Exchange 2000 Server and Exchange Server 2003 performance may be affected when desktop search engine software is running on Outlook or other MAPI client computers


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Summary

This article describes problems that may occur on the Outlook or MAPI client computer and on the Exchange server when client computer users use a desktop search engine. This article describes how to identify users who are using desktop search engines. This article also describes the following methods that you can use to reduce the problems that are caused by desktop search engines:
  • Use Exchange Cached Mode in Microsoft Office Outlook 2003.
  • Plan for desktop search engine use when you plan your Exchange server environment.
  • Use client�side software policies to prevent users from using desktop search engines.
  • Consider using Exchange content indexing.

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Symptoms

If you use a Microsoft Outlook 2002 or Microsoft Office Outlook 2003 client computer, you may experience delays. Additionally, you may receive the following RPC connection message:
Outlook is requesting information from the Exchange server.
If you use a client computer that is running an earlier version of Outlook or use another MAPI client computer, you may experience delays. Or, the computer may appear to stop responding (hang). On a server that is running Microsoft Exchange 2000 Server or Microsoft Exchange Server 2003, you may notice higher CPU use in the Store.exe process or higher than expected database disk activity.

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Cause

This problem occurs if the Outlook client computer or the other MAPI client computer is running a desktop search engine that integrates with Outlook to index the user's mailbox or public folder data that resides on the Exchange server.

The number of users who use desktop search engines, such as MSN Desktop Search, is increasing. The presence of desktop search engines in a user base can double or triple the load on an Exchange server. The increased, or non-optimal, use of server resources leads to a perception of poor performance on the client computer. The increased use of server resources also leads to noticeable server performance hits. These problems have been observed with several different desktop search engines that integrate with the mailbox search functionality.

The following problems may occur when users use desktop search engines:
  • Increased CPU use and disk I/O spikes on the Exchange server
  • RPC bottlenecks on the client side
  • Increased RPC operations per second on the Exchange server
These problems may lead to increased overall RPC Averaged Latency values on the Exchange server. Increased RPC Averaged Latency values may cause the symptoms that are described in the "Symptoms" section. On the client computer, the desktop search engine may submit lots of RPC requests to the server. This causes a client-side RPC bottleneck. When a client-side RPC bottleneck occurs, a delayed RPC response may occur even though the server is operating as expected and no network connectivity issues are occurring.

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Resolution

How to identify users who are running desktop search engines

To help identify the users who may be using a desktop search engine against the Exchange server, you can use the Microsoft Exchange Server User Monitor tool (Exmon.exe).

The following file is available for download from the Microsoft Download Center:
Download the Exmon.exe package now.
For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.


For information about how to use the Exchange Server User Monitor tool, see the tool usage documentation that is available in the installation folder after you install the tool.


You can use this tool to help you identify specific MAPI clients that are responsible for the highest activity on the server.

Additionally, you can use the Microsoft Exchange Server Performance Troubleshooting Analyzer Tool to help you collect performance information and analyze the information that the EXMON.EXE tool creates. To download the Microsoft Exchange Server Performance Troubleshooting Analyzer Tool, visit the following Microsoft Web site:

How to reduce the number of problems that are related to a desktop search engine

To reduce the number of problems that are related to a desktop search engine, use one or more of the following methods.

Method 1: Use the Exchange Cached Mode feature in Outlook 2003

When you configure Outlook 2003 to run in Exchange Cached Mode, the desktop search engine searches the local copy of the mailbox instead of the mailbox content that is on the server.

Note This method will not be useful if the desktop search engine includes an option to search Exchange public folders. Public folders are not cached. However, not all desktop search engines include an option to search public folders.

Method 2: Plan for an increased load when you plan your Exchange server environment

If you expect that users will run desktop search engines on the client computers, plan for an increased load when you plan your Exchange server environment if the following conditions are true:
  • Users will not be using Outlook 2003 in Exchange Cached Mode.
  • Users will be using an earlier version of Outlook.
  • Users will be using another MAPI client.
The following list includes some general guidelines to plan your Exchange server environment:
  • Make sure that the Exchange server has enough CPU capacity and enough disk I/O bandwidth to handle the expected load that will be added when users use desktop search engines. The exact performance effect on your environment should be measured and compared with the performance baseline. For more information about how to collect performance information and to create a baseline, see the following Microsoft Web sites:
  • Because indexing times and frequency are controlled by the client and not by the server, the server may experience increased CPU use and disk I/O spikes. In an existing Exchange environment, you can use these spikes to approximate when indexing is occurring. Then, you can plan the Exchange server performance upgrades accordingly. If you are building a new Exchange server environment, you can build a lab to test the effect of multiple clients that perform content indexing of their mailbox stores. You can use the results of this test to plan the performance specifications for the Exchange server. When you are building a new Exchange server environment, you may be able to schedule groups of client computers to perform content indexing to balance the performance load on the Exchange server.
  • Monitor the memory use on the server. For more information, visit the following Microsoft Web site:
  • Monitor the server for virtual memory fragmentation.
  • Monitor the server for event ID 9646 messages. Event ID 9646 messages may be logged when a search engine on the client computer opens many objects on the server. For more information about the event ID 9646 message, click the following article number to view the article in the Microsoft Knowledge Base:
    830829 Your Exchange Server 2003 computer may stop responding after a MAPI client opens more than the default value of certain server objects

Method 3: Prevent the users from using desktop search engines

You can use client-side software policies to prevent users from using desktop search engines.

Method 4: Consider enabling Exchange content indexing

You may want to evaluate the benefits of enabling Exchange content indexing. Sometimes, you may find that if you enable Exchange content indexing, you may receive search results faster when you run a search against the mailbox content than when you use a desktop search engine on the client computer.

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References

For more information about how to isolate performance issues, see the Troubleshooting Exchange Server 2003 Performance guide. To view the Troubleshooting Exchange Server 2003 Performance guide, visit the following Microsoft Web site:

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Keywords: KB905184, kbexchtechbulletin

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Article Info
Article ID : 905184
Revision : 9
Created on : 11/27/2007
Published on : 11/27/2007
Exists online : False
Views : 419