Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

How to make the "Find Printer" button unavailable in Office XP programs


View products that this article applies to.

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/ ) Description of the Microsoft Windows Registry

↑ Back to the top


Symptoms

When you print in a Microsoft Office XP program, the Find Printer button is available in the Print dialog box.

↑ Back to the top


Cause

If you are a network administrator, you may not want your users to be able to browse the network to locate other printers than the ones that they are assigned to print to. If you apply the Disable Addition of Printers policy in Microsoft Windows, Office XP programs may not honor the policy.

For more information about the Disable Addition of Printers, visit the following Microsoft Web site:

↑ Back to the top


Resolution

How to obtain the hotfix

This issue is fixed in the Office XP Post-Service Pack 2 Hotfix Package that is dated October 23, 2003. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
829349� Description of the Office XP post-Service Pack 3 hotfix package: May 9, 2004

After you install this hotfix, follow the steps that are listed in the "More Information" section of this article to set the NoAddPrinter registry key and to activate the hotfix.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
To activate this hotfix, follow these steps:
  1. Quit all programs.
  2. Click Start, and then click Run.
  3. In the Open box, type regedit, and then click OK.
  4. Locate, and then click to select the following registry key:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
  5. After you select the key that is specified in step 4, point to New on the Edit menu, and then click DWORD Value.
  6. Type NoAddPrinter, and then press ENTER.
  7. Right-click NoAddPrinter, and then click Modify.
  8. In the Value data box, type 1, and then click OK.
  9. On the File menu, click Exit to quit Registry Editor.

↑ Back to the top


Keywords: KB835214, kbbug, kbfix, kbofficexppostsp3fix, kbhotfixserver, kbqfe

↑ Back to the top

Article Info
Article ID : 835214
Revision : 5
Created on : 11/2/2007
Published on : 11/2/2007
Exists online : False
Views : 390