Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"HTTP 404" error message when you use OWA to open an item that is posted to a public folder in Exchange 2000 Server


View products that this article applies to.

Symptoms

If you try to open an item that is posted to a public folder using the Microsoft Outlook Web Access (OWA) client, you may receive the following error message:
HTTP 404 - File not found

↑ Back to the top


Cause

This problem occurs if the name of the Microsoft Exchange 2000 Server public folder that contains the item ends in a period.

↑ Back to the top


Resolution

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Because of file dependencies, this update requires Microsoft Exchange 2000 Server Service Pack 3 (SP3). For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
301378 How to obtain the latest Exchange 2000 Server service pack

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   15-Oct-2003  23:31  6.0.6521.0      3,915,776  Cdoex.dll        
   15-Oct-2003  23:25  6.0.6521.0        851,968  Davex.dll        
   15-Oct-2003  23:25  6.0.6521.0         53,248  Davexpc.dll      
   15-Oct-2003  23:22  6.0.6521.0        131,072  Drviis.dll       
   15-Oct-2003  23:22  6.0.6521.0        577,536  Dsaccess.dll     
   15-Oct-2003  22:33  6.0.6521.0        184,320  Dscmsg.dll       
   15-Oct-2003  22:33  6.0.6521.0        962,560  Emsmdb32.dll     
   15-Oct-2003  23:25  6.0.6521.0      2,179,072  Ese.dll          
   15-Oct-2003  23:25  6.0.6521.0         40,960  Eseperf.dll      
   09-Sep-2003  02:18                      6,991  Eseperf.hxx
   15-Oct-2003  23:25                    391,634  Eseperf.ini
   15-Oct-2003  23:31  6.0.6521.0      3,575,808  Excdo.dll        
   15-Oct-2003  23:22  6.0.6521.0        262,144  Exmime.dll       
   15-Oct-2003  23:25  6.0.6521.0        143,360  Exodbesh.dll     
   15-Oct-2003  23:25  6.0.6521.0         57,344  Exodbpc.dll      
   15-Oct-2003  23:25  6.0.6521.0        200,704  Exodbprx.dll     
   15-Oct-2003  23:25  6.0.6521.0      2,179,072  Exoledb.dll      
   15-Oct-2003  23:20  6.0.6521.0         81,920  Exosal.dll       
   15-Oct-2003  23:25  6.0.6521.0        307,200  Exprox.dll       
   15-Oct-2003  22:36  6.0.6521.0        143,360  Exschema.exe     
   15-Oct-2003  23:25  6.0.6521.0        315,392  Exsmtp.dll       
   15-Oct-2003  22:38  6.0.6521.0        675,840  Exwform.dll      
   15-Oct-2003  23:23  6.0.6521.0         40,960  Jcb.dll          
   15-Oct-2003  22:13  6.0.6521.0         49,152  Mdbevent.dll     
   15-Oct-2003  22:30  6.0.6521.0      2,285,568  Mdbmsg.dll       
   15-Oct-2003  22:15  6.0.6521.0         32,768  Mdbrole.dll      
   15-Oct-2003  23:23  6.0.6521.0         24,576  Mdbtask.dll      
   15-Oct-2003  23:19  6.0.6521.0         94,208  Peexch50.dll     
   15-Oct-2003  23:20  6.0.6521.0        397,312  Phatcat.dll      
   15-Oct-2003  23:23  6.0.6521.0        532,480  Reapi.dll        
   15-Oct-2003  23:25  6.0.6521.0        311,296  Resvc.dll        
   15-Oct-2003  23:21  6.0.6521.0      4,657,152  Store.exe        
   15-Oct-2003  22:38  6.0.6521.0      3,735,552  Wmtemplates.dll  
				

↑ Back to the top


Workaround

To work around this problem, rename the public folder to delete the trailing period.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server.

↑ Back to the top


More information

For additional information about Microsoft software updates, click the following article numbers to view the articles in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
817903 New naming schema for Exchange Server software update packages

↑ Back to the top


Keywords: kbautohotfix, kbhotfixserver, kbqfe, kbqfe, kbfix, kbexchange2000presp4fix, kbbug, KB820924

↑ Back to the top

Article Info
Article ID : 820924
Revision : 6
Created on : 10/26/2006
Published on : 10/26/2006
Exists online : False
Views : 431