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"Thank you for your interest in Windows Update" message when you connect to the Windows Update Web site


View products that this article applies to.

Symptoms

When you try to connect to the Windows Update Web site (http://windowsupdate.microsoft.com), you may be unexpectedly redirected to a Web page that displays a message that is similar to the following:
Thank you for your interest in Windows Update

Windows Update is the online extension of Windows that helps you get the most out of your computer ...

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Cause

This behavior may occur for any of the following reasons:
  • You are not running a release-to-manufacturing (RTM) (non-beta) version of Windows 98, Windows 98 Second Edition, Windows Millennium Edition, Windows NT 4.0, Windows 2000, Windows XP, or Windows Server 2003, or you are running Windows 2000 Datacenter Server.
  • You are not running an RTM version of Microsoft Internet Explorer 5 or later. For example, you are running a beta version of Internet Explorer, or you are not running Internet Explorer.
  • Windows Update incorrectly detects that you are not running a released version of Internet Explorer 5 or later on a supported Windows operating system. This may occur if you access the Internet through a firewall or proxy that does not allow the Windows Update Web site to receive the correct HTTP user-agent request header ("HTTP_USER_AGENT") for Internet Explorer. Windows Update uses the operating system information that the navigator.userAgent property returns to determine if you are running a supported operating system. Some firewalls or proxy servers may send user-agent information that is incorrect or difficult to interpret.

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Resolution

To use Windows Update, you must be running an RTM version of Internet Explorer 5 or later on a Windows 98, Windows 98 Second Edition, Windows Millennium Edition, Windows NT 4.0, Windows 2000 (except Datacenter Server), Windows XP, or Windows Server 2003-based computer. To resolve this behavior, use the appropriate method:

Method 1: Upgrade Windows or Internet Explorer

If you are not running an RTM version of Windows 98, Windows 98 Second Edition, Windows Millennium Edition, Windows NT 4.0, Windows 2000 (except Datacenter Server), Windows XP, or Windows Server 2003, or you are running a beta version of Internet Explorer or a version of Internet Explorer earlier than version 5, then upgrade to the latest released version of Windows and Internet Explorer. For more information about how to determine which version of Internet Explorer you are running and how to upgrade it, click the following article number to view the article in the Microsoft Knowledge Base:
164539� How to Determine Which Version of Internet Explorer Is Installed
Note Windows Update does not currently support updates for Windows 2000 Datacenter Server. Contact your service provider to receive updates to Windows 2000 Datacenter Server.

Method 2: Use Internet Explorer 5 or later or the Microsoft Download Center

If you are using a non-Microsoft browser, you can instead either use Internet Explorer 5 or later to access the Windows Update site or download updates from the Microsoft Download Center by using your non-Microsoft browser:

Method 3: Configure your firewall or proxy to allow Windows Update to receive the Internet Explorer user-agent request header

Configure your firewall or proxy to allow Windows Update to receive the HTTP user-agent request header that Internet Explorer sends. Contact your network or system administrator or see the documentation included with your proxy or firewall for information about how to do this.

For information about your hardware manufacturer, visit the following Web site:

Method 4: Modify the registry

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756� How to back up and restore the registry in Windows


Back up and then delete the following registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\User Agent\Post Platform
To back up and then delete the registry key, follow these steps:
  1. Click Start, and then click Run.
  2. In the Open box, type regedit, and then click OK.
  3. Locate, and then click the following registry key:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\User Agent\Post Platform
  4. On the File menu, click Export.
  5. In the File name box, type Post Platform, and then click Save.
  6. On the Edit menu, click Delete.
  7. Click Yes when you are prompted to confirm the deletion.
  8. Quit Registry Editor.
  9. If this does not resolve the problem, double-click the Post Platform.reg file that you saved in step 5 to import this key back into the registry.

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More information

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

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Keywords: KB817144, kbprb, kbbug

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Article Info
Article ID : 817144
Revision : 17
Created on : 5/23/2007
Published on : 5/23/2007
Exists online : False
Views : 462