Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

BizTalk Server uses the <prop:identity> element instead of the <rcpt:identity> element for receipts


View products that this article applies to.

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/ ) Description of the Microsoft Windows registry

↑ Back to the top


Symptoms

BizTalk Server is not compliant with the BizTalk Framework. The BizTalk Framework 2.0: Document and Message Specification states that the //deliveryReceipt/identity element belongs to the http://schemas.biztalk.org/btf-2-0/receipts namespace. However, the //deliveryReceipt/identity element declares the http://schemas.biztalk.org/btf-2-0/properties namespace.

If you send messages in a BizTalk Framework envelope to BizTalk Server and you request a delivery receipt, the delivery receipt does not comply with the BizTalk Framework specification. For example, the following line is listed in the delivery receipt:
<prop:identity xmlns:prop="http://schemas.biztalk.org/btf-2-0/properties">uuid:31C24EF4-EF6C-4DAE-8CE0-ACDE53AAEFC6</prop:identity>
This line should be:
<rcpt:identity xmlns:prop="http://schemas.biztalk.org/btf-2-0/properties">uuid:31C24EF4-EF6C-4DAE-8CE0-ACDE53AAEFC6</rcpt:identity>

↑ Back to the top


Cause

This problem occurs because the code does not use the <rcpt:identity> element. Instead, the code uses <prop:identity> element.

↑ Back to the top


Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft BizTalk Server 2002. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
815781� How to obtain the latest BizTalk Server 2002 service pack

Hotfix information

For compatibility between service pack levels and versions of BizTalk Server, this hotfix is an all or nothing scenario. You should install this hotfix or BizTalk Server 2002 Service Pack 1 on all servers that are running BizTalk Server 2002. These include partners. You should also install this hotfix if servers that are running BizTalk Server 2000 are also in the environment. These include partners.

BizTalk Server 2002

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version     Size	  File name		 
------------------------------------------------------
06-Dec-2002  21:58  3.0.1554.0  721,168  Cisparser.dll


BizTalk Server 2000

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version     Size	  File name		 
------------------------------------------------------
31-Jul-2003  14:29  2.0.2009.0  680,208   Cisparser.dll
31-Jul-2003  14:29  2.0.2009.0  688,400   Ciscore.dll

↑ Back to the top


More information

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

After you install this service pack or hotfix, you must create the following registry entry and set the value of the entry to 1 to cause BizTalk to use the new receipt format (<rcpt:identity�>). If you install this service pack or hotfix, compatibility issues may occur when you exchange receipts between two BizTalk Server systems if the service pack or hotfix has not been installed on both systems and if both systems are not generating receipts by using the new format.
Collapse this tableExpand this table
Key NameTypeLocation
UseFixedReceiptFormatREG_DWORDHKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BTSSvc
To create this value in the registry, follow these steps:
  1. Click Start, click Run, and type regedit.
  2. Locate the registry entry, and then create a new DWORD value by using the information in the table.

    A value of 1 indicates that the new receipt format (<rcpt:identity�>) is generated, and a value of 0 indicates that the original receipt format (<prop:identity�>) is generated.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

This problem was first corrected in Microsoft BizTalk Server 2002 Service Pack 1.

↑ Back to the top


Keywords: KB811092, kbfix, kbbiztalk2002sp1fix, kbqfe, kbhotfixserver, kbautohotfix

↑ Back to the top

Article Info
Article ID : 811092
Revision : 13
Created on : 11/15/2007
Published on : 11/15/2007
Exists online : False
Views : 453