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You receive an error message when you open either a SharePoint team Web site or another Web site with the FrontPage Server Extensions that uses a ISAPI filter that modifies server headers


View products that this article applies to.

This article was previously published under Q329362

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Symptoms

When you use an Internet Server Application Programming Interface (ISAPI) filter that modifies server headers, your Web site that is based on SharePoint Team Services may display the following text at the top of each page on your Web site:
Content-type: text/html pragma: no-cache cache-control: no-cache expires: 0
Additionally, when you try to open a SharePoint team Web site or try to open another Web site with the Microsoft FrontPage Server Extensions, the following error message is displayed by the Microsoft FrontPage client:
An error occurred accessing your FrontPage Web files.
Authors - if authoring against a web server, please contact the webmaster for this server's site.
WebMasters - please see the server's system log for more details.

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Cause

This problem occurs when an ISAPI filter modifies the server headers before the server headers are sent to the client. When the ISAPI filter makes changes to the server headers, Internet Information Services (IIS) sends the headers to the client before SharePoint Team Services or the FrontPage Server Extensions have had a chance to append additional custom headers in the HTTP data stream. This issue causes an unexpected end-of-header marker in the data that is being sent to the client, and causes the error message that is mentioned in the "Symptoms" section of this article.

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Workaround

To work around this problem, either remove the ISAPI filter that is modifying the server headers or reconfigure the ISAPI filter so that is does not modify the server headers.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

When the Microsoft FrontPage or the Web Folders client technologies issue an HTTP GET request to the FrontPage Smart HTML Interpreter DLL, the Shtml.dll file, on a Web server where there are not any ISAPI filters configured, the raw HTTP response may be similar to the following example:
HTTP/1.1 200 OK{CRLF}
Server: Microsoft-IIS/5.0{CRLF}
Date: Sun, 1 Jan 2000 12:00:00 GMT{CRLF}
MicrosoftOfficeWebServer: 5.0_Pub{CRLF}
Connection: close{CRLF}
Content-Type: text/html; charset=windows-1252{CRLF}
{CRLF}
<HTML><BODY>Cannot run the FrontPage Server Extensions on this page: ""</BODY></HTML>
In this example, the server returns several headers to the client, including the Server type (in this scenario, Microsoft-IIS/5.0 is the Server type header that is returned) and the Date. The end-of-header marker is the blank line where only the carriage-return line-feed (CRLF) characters are present.

When you install an ISAPI filter that modifies the server headers in combination with SharePoint Team Services or the FrontPage Server Extensions, an extra end-of-header marker is inserted, and you receive the error message that is mentioned in the "Symptoms" section of this article.

In the following example, the URLScan utility has been configured to modify the server header to return a non-existent TEST/1.0 server type instead of the default Microsoft-IIS/5.0 server type:
HTTP/1.1 200 OK{CRLF}
Date: Sun, 1 Jan 2000 12:00:00 GMT{CRLF}
MicrosoftOfficeWebServer: 5.0_Pub{CRLF}
Connection: close{CRLF}
Server: TEST/1.0{CRLF}
{CRLF}
Content-Type: text/html; charset=windows-1252{CRLF}
{CRLF}
<HTML><BODY>Cannot run the FrontPage Server Extensions on this page: ""</BODY></HTML>
In the first example in this section, the server header is followed by a blank line that contains only the CRLF characters, signifying the end of the headers, and this is followed by another server header from the FrontPage Smart HTML Interpreter DLL, the shtml.dll file. The FrontPage Smart HTML Interpreter DLL, the shtml.dll file, overrides the default content type. Because this information is returned after a blank line that contains only the CRLF characters, it is considered to be part of the body of the HTTP data stream instead of part of the headers. Because of this situation, the FrontPage client cannot correctly process the response, and you receive the error message that is mentioned in the "Symptoms" section of this article.

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References

For additional information about how to use the URLScan with FrontPage and SharePoint technologies, click the following article numbers to view the articles in the Microsoft Knowledge Base:
307608� Using URLScan on IIS
326444� How to configure the URLScan tool
307976� You receive an error message when you use FrontPage with URLScan
309394� How to use URLScan with FrontPage 2000
318290� How to use URLScan with FrontPage 2002

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Keywords: KB329362, kbbug, kberrmsg, kbpending

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Article Info
Article ID : 329362
Revision : 3
Created on : 2/21/2007
Published on : 2/21/2007
Exists online : False
Views : 327