Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

PRB:


View products that this article applies to.

This article was previously published under Q326144

↑ Back to the top


Symptoms

When you try to start the BizTalk Orchestration Designer, you may receive the following error message:
Problem in General.startVisio
Error Number: 70
Error Description: Permission denied
After you click OK to dismiss this error message, you receive the following error message:
BizTalk Orchestration Designer cannot start Microsoft Visio.

Check your Visio installation and try starting BizTalk
Orchestration Designer again.
After you click OK to dismiss this error message, the BizTalk Orchestration Designer closes.

↑ Back to the top


Cause

This problem occurs if the user who is trying to start the BizTalk Orchestration Designer does not have the "Allow Access" permission for Distributed COM (DCOM) applications.

↑ Back to the top


Resolution

To resolve this problem, add the user who is trying to start the BizTalk Orchestration Designer to the list of users who are permitted access to applications that do not provide their own settings. To do this, follow these steps:
1.Click Start, click Run, type DCOMCNFG, and then click OK.
2.On the Default Security tab, click Edit Default.
3.In the Names list, click the user, the users, the group, or the groups.
4.In the Type of Access list, click Allow Access.
5.Click OK to close the Dcomcnfg.exe utility.

↑ Back to the top


Status

This behavior is by design.

↑ Back to the top


More information

By default, the list of users who can access applications that do not provide their own settings is blank in the Dcomcnfg.exe utility. When this list is blank, only the SYSTEM and Principal users are granted the "Allow Access" permission. As soon as an entry is added to the list, the "Allow Access" permission is restricted to only those entries that are listed.

This problem occurs when an application adds an entry to the list that was previously blank, which then limits access to only that entry.

↑ Back to the top


Keywords: KB326144, kbprb

↑ Back to the top

Article Info
Article ID : 326144
Revision : 4
Created on : 6/4/2003
Published on : 6/4/2003
Exists online : False
Views : 273