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PRB: The BizTalk Messaging Manager Error "The Download of the Specified Resource Has Failed" Occurs


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Symptoms

When you use the BizTalk Server Messaging Manager to save a Channel, a Document a Definition, or an Envelope that references a specification or map in a WebDAV repository, you may receive an error message that is similar to the following:
The Channel could not be saved.

Error 0x80004005: The download of the specified resource has failed.
-- http://servername/BizTalkServerRepository/DocSpecs/mydoc.xml
This error can occur regardless of your current logon credentials.

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Cause

This error can occur if:
  • The Microsoft Internet Information Services (IIS) virtual directory, /MessagingManager, is running under the context of an account that does not have the appropriate permissions to a necessary file or registry resource.

    -or-
  • The account that you are logged on with while you are accessing the BizTalk Messaging Manager does not have the appropriate permissions to a necessary file or registry resource.

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Resolution

To resolve this behavior:
  • Grant the appropriate permissions for these accounts to any required file or registry resources. These accounts need Modify permissions to the Temporary Internet Files folder location that is specified on the Internet Options tab in Microsoft Internet Explorer in addition to Read permission to the following registry key and its subkeys:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings
    To check permissions for the Temporary Internet Files folder location that is specified for the account that BizTalk Messaging Service is running under the context of, locate the following folder:
    \Documents and Settings\BizTalkServiceAcct\Local Settings\Temporary Internet Files\
    By default, the permissions are located in this folder.

    -or-
  • Change the account that the /MessagingManager virtual directory is running under the context of to an account that has the appropriate rights to the registry or file system (or both).

    -or-

    Log on with an account that has the appropriate rights to the registry or file system (or both) while accessing the BizTalk Messaging Manager.

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Status

This behavior is by design.

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More information

To determine the account that the /MessagingManager virtual directory is running under the context of:
  • In the Internet Information Services Microsoft Management Console (MMC), right-click the /MessagingManager virtual directory, and then click Properties.
  • On the Virtual Directory tab, make a note of the level that is specified in the Application Protection box.
The following table lists the accounts that are used for different levels of IIS application isolation:

Application ProtectionAccount Used
Low(IIS Process)Determined by the Identity of IIS In-Process Applications COM+ package.
Medium(Pooled)Determined by the Identity of IIS Out-Of-Process Pooled Applications COM+ package.
High(Isolated)Determined by the Identity of COM+ package that is created when the virtual directory is marked with an Application Protection level of High(Isolated).

To determine the actual Identity that is used by the COM+ packages that are listed in the table:
  • Start the Component Services snap-in.
  • Right-click the package that corresponds to the level of application protection, and then click Properties.
  • Click the Identity tab.
After you grant the appropriate file-level and registry-level permissions to the appropriate account (or changing this account), you may have to stop and restart IIS to make sure that the permission changes take effect for the /MessagingManager IIS application.

To stop and restart IIS, run the iisreset command from the command prompt.

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Keywords: KB321546, kbprb, kbnofix

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Article Info
Article ID : 321546
Revision : 6
Created on : 12/26/2006
Published on : 12/26/2006
Exists online : False
Views : 492