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PRB: Documents That Are Sent Through the HTTP/HTTPS Transport to an ASP Page Fail Delivery


View products that this article applies to.

This article was previously published under Q320380

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Symptoms

When BizTalk Server sends documents through the HTTP/HTTPS transport to an ASP page that is located on a Microsoft Internet Information Services (IIS) server, document delivery fails and the documents are placed in the suspended queue of the sending BizTalk Server. In this scenario, an error that is similar to the following one is generated in the BizTalk Server Application log:
Event Type:	Error
Event Source:	BizTalk Server
Event Category:	Document Processing 
Event ID:         324
Date:		<I BRACKET="YES">MM/DD/YY</I>
Time:		<I BRACKET="YES">HH:MM:SS</I> PM
User:		N/A
Computer:         BIZTALKSERVER
Description:
An error occurred in BizTalk Server.
 
 Details:
 ------------------------------
[0x80004005] An error occurred during transmission:
Request information:

Proxy:
Proxy port:80
URL:http://<receivingserver>/response.asp
Content-Type:text/plain; charset="utf-8"
User name:
Client certificate:
Request body:3313 Bytes
Timeout duration (seconds): 99
Error code:80004005
====== ERROR =====
The HTTP server returned an unexpected response: 500  Internal Server Error
The following response was received:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 Final//EN">

<html dir=ltr>

<head>
<style>
a:link			{font:8pt/11pt verdana; color:FF0000}
a:visited		{font:8pt/11pt verdana; color:#4e4e4e}
</style>

<META NAME="ROBOTS" CONTENT="NOINDEX">

<title>The page cannot be displayed</title>

<META HTTP-EQUIV="Content-Type" Content="text-html; charset=Windows-1252">
</head>

<script> 
function Homepage(){
<!--
// in real bits, URLs are returned to the script as such:
// res://shdocvw.dll/http_404.htm#http://www.DocURL.com/bar.htm 

//For testing, use DocURL = "res://shdocvw.dll/http_404.htm#https:/HTTP 
[0x0159] The server encountered a transport error while processing the 
messaging port "SendHTTP", which uses a transport component with a ProgID 
of "BizTalk.SendHTTPX.1". 

[0x012a] All retry transmissions failed.

[0x80004005] Unspecified error

[0x0156] The server could not finish processing messaging port "SendHTTP". 

[0x1730] Suspended Queue ID: "{D8BA4213-9F17-49A0-AF7E-1F27B5A20304}" 

[0x80004005] Unspecified error   
					

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Cause

This behavior can occur if the ScriptTimeout variable of the receiving IIS server is set to a number that is too low.

If the HTTP/HTTPS transport cannot deliver the document to the designated IIS server within the timeframe that is specified in the ScriptTimeout setting, the receiving ASP page aborts the transmission of the incoming document and sends a "500 Internal Server Error" back to the BizTalk Server.

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Resolution

To resolve this behavior, use any of the following three methods to increase the IIS server ScriptTimeout setting:

Method 1

Increase the time that is allowed to process ASP scripts for a particular Web site. To do this, change the metabase value in IIS:
  1. Start Internet Services Manager.
  2. Right-click Default Web Site (or the site that has the problem), and then click Properties.
  3. On the Home Directory tab, under Application Settings, click Configuration.
  4. On the App Options tab, increase the ASP Script Timeout value to a number that is high enough to prevent script timeouts.

Method 2

Increase the time that is allowed to process ASP scripts for all Web sites. To do this, change the metabase value in IIS:
  1. Start Internet Services Manager.
  2. Right-click Computer_Name where Computer_Name is the name of your computer, and then click Properties.
  3. In Master Properties, click WWW Service, and then click Edit.
  4. On the Home Directory tab, under Application Settings, click Configuration.
  5. On the App Options tab, increase the ASP Script Timeout value to a number that is high enough to prevent script timeouts.

Method 3

Use the Server.ScriptTimeOut property to programmatically increase the ScriptTimeOut property value at the page level in ASP.

For example, if you want 3 minutes to pass before script processing times out, add the following line to the ASP page:
Server.ScriptTimeout = 180
				
NOTE: When you set the script timeout at the page level, you cannot set it to less than the metabase value in IIS, which is 90 seconds by default; however, you can set the script timeout to a value that is higher than the metabase value.

For example:
  • If you do not change the metabase default, and you code the following
    Server.ScriptTimeout = 20
    						
    the ScriptTimeOut value is 90.

    -or-
  • If you code the following
    Server.ScriptTimeout = 120
    						
    the ScriptTimeOut value is 120.

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Status

This behavior is by design.

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More information

This problem may not become apparent unless BizTalk Server is attempting to transmit a large document to the destination IIS server by using the HTTP/HTTPS transport.

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References

For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
268364� PRB: 'Script Time Out' Error in Active Server Pages (ASP)

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Keywords: KB320380, kbprb, kbpending

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Article Info
Article ID : 320380
Revision : 5
Created on : 6/4/2003
Published on : 6/4/2003
Exists online : False
Views : 499