Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

OFFXP: An Arabic Presentation Forms Character Changes to a Question Mark in an Enhanced Metafile


View products that this article applies to.

This article was previously published under Q304648
NOTE: This article discusses complex scripts functionality. Complex scripts functionality is available when you use the Office Language Settings tool to enable a language, such as Arabic or Hebrew, that requires this functionality. For more information about multilingual features, click Microsoft <I BRACKET="YES">your Office product</I> Help on the Help menu, type multilingual features in the Office Assistant or the Answer Wizard, and then click Search to view the topics that are returned.

↑ Back to the top


Symptoms

If you insert an Arabic Presentation Forms character into an Enhanced Metafile (.emf), the inserted character may change to a question mark. This problem may occur in the following cases.

Case 1

If you insert an Arabic character into a Word Picture object.

For example, if you do the following in a program such as PowerPoint, Arabic characters may appear as question marks:
  1. On the Insert menu, you select Object.
  2. In the Insert Object dialog box, you select Microsoft Word Picture.

Case 2

If you paste text that contains Arabic characters from one Office program into another Office program.

For example, this problem occurs if you do the following:
  1. On the Edit menu, you click Paste Special.
  2. In the Paste Special dialog box, you select Picture.

Case 3

If the Arabic characters are included in the preview text that appears in the Open dialog box, the Arabic characters may appear as question marks.

For example, if you do the following:
  1. On the File menu, you click Open.
  2. You select the document that you want to open.
NOTE: To preview the document in the Open dialog box, change the Views list to Preview.

Case 4

If you send a presentation from PowerPoint to Word in one of the layouts that includes the individual slides as pictures, Arabic characters may appear as question marks.

For example, if you do the following:
  1. On the File menu, you point to Send To and then click Microsoft Word to send a presentation from PowerPoint.
  2. In the Send to Microsoft Word dialog box, you select Paste link.

↑ Back to the top


Workaround

Case 1

To work around this problem, in the Insert Object dialog box, select Microsoft Word Document, and then insert the Arabic character.

Case 2

To work around this problem, do one of the following:
  • On the Insert menu, click Paste.

    -or-
  • In the Paste Special dialog box (on the Edit menu, click Paste Special), select any of the options except Picture.

Case 3

To prevent this problem from occurring, on the File menu, click Properties. On the Summary tab, clear the Save preview picture check box.

Case 4

To work around this problem, in the Send to Microsoft Word dialog box, select Paste or Outline Only.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

↑ Back to the top


Keywords: KB304648, kbprb, kbnofix

↑ Back to the top

Article Info
Article ID : 304648
Revision : 3
Created on : 1/31/2007
Published on : 1/31/2007
Exists online : False
Views : 341