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Include components and shared borders are displayed incorrectly on IIS


View products that this article applies to.

Symptoms

After you upgrade your Microsoft Internet Information Services-based Web site to FrontPage 2002 Server Extensions or SharePoint Team Services from Microsoft, the include components and shared borders are not displayed correctly. The body of the main page is displayed as part of the shared border or the include component, appearing to duplicate data throughout the page. Also, after you insert a PhotoGallery or an Include page, you see the path to the page rather than the content of the page. In Normal view in FrontPage, the page appears correctly, but when you view it in a Web browser, you see only the path.

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Cause

This problem is caused by the configuration of the performance tuning settings on the server, in particular, the Max Cache Document Size setting. For information about how to configure these settings, see the "More Information" section later in this article.

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Workaround

Remove the registry keys that affect the components. To do this, follow these steps.

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

Global Settings

IMPORTANT: Follow these steps carefully, because these settings affect all sites on your server.
  1. On the Windows Start menu, click Run.
  2. In the Open box, type regedit and then click OK.
  3. Locate the following registry key:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Shared Tools\Web Server Extensions\All Ports
  4. Remove the following entries:
    • CacheMaxDocMeta
    • CacheMaxInclude
    • CacheMaxImage
    • CacheMaxIncludeSize
  5. Quit Registry Editor.
  6. Recalculate any affected Webs on the Web server.

Site-Specific Settings

IMPORTANT: Follow these steps for each site that is still experiencing problems.
  1. On the Windows Start menu, click Run.
  2. In the Open box, type regedit and then click OK.
  3. Locate the following registry subkey
    HKEY_LOCAL_MACHINE\Software\Microsoft\Shared Tools\Web Server Extensions\Ports\Port /LM/W3SVC/#:
    where # is the Microsoft Internet Information Services (IIS) instance of the site.

  4. Remove the following entries:
    • CacheMaxDocMeta
    • CacheMaxInclude
    • CacheMaxImage
    • CacheMaxIncludeSize
  5. Quit Registry Editor.
  6. Recalculate any affected Webs on the specific Web site.

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Resolution

To resolve this problem, obtain the latest service pack for Microsoft Office XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
307841 OFFXP: How to Obtain the Latest Office XP Service Pack

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Office XP Service Pack 1.

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More information

For additional information about this problem and UNIX servers, click the following article number to view the article in the Microsoft Knowledge Base:
299360 FP: Include Component and Shared Borders Are Displayed Incorrectly on UNIX Servers

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Keywords: kbnosurvey, kbarchive, kbupgrade, kbwebserver, kbdisplay, kbofficexpsp1fix, KB298827

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Article Info
Article ID : 298827
Revision : 5
Created on : 2/28/2014
Published on : 2/28/2014
Exists online : False
Views : 467