Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Exchange Online users can't keep messages for longer than 14 days in Office 365


View products that this article applies to.

Problem

When Exchange Online users try to recover an email item that was deleted more than 14 days ago, they discover that they can't do so.

↑ Back to the top


Cause

By default, the period in which deleted items are available for recovery in Exchange Online is 14 days. After 14 days, these items are no longer available in the Recover Deleted Items folders in Microsoft Outlook or in Microsoft Outlook Web App.

↑ Back to the top


Solution

The exact resolution for this issue varies depends on the length of the period that you want to make deleted items available for recovery.

To recover items that were deleted no more than 30 days ago

To recover items that were deleted no more than 30 days ago, increase the Deleted item recovery (Single Item Recovery) period for all users from the default of 14 days to the 30 day maximum. To have us fix the problem for you, go to the "Fix it for me" section. If you prefer to fix this problem yourself, go to the "Let me fix it myself" section.

Fix it for me

To increase the Deleted item recovery (Single Item Recovery) period automatically, click the Fix it button or link. Then click Run in the File Download dialog box, and follow the steps in the Fix it wizard.

Fix this problem
Microsoft Fix it 50941



Notes
  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.
  • If you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD, and then run it on the computer that has the problem.
Then, go to the "Did this fix the problem?" section.

Let me fix it myself

To increase the Deleted item recovery (Single Item Recovery) period for all users from the default of 14 days to the 30 day maximum, follow these steps:
  1. Connect to Exchange Online by using remote PowerShell. For more info about how to do this, go to the following Microsoft website:
  2. Run a Windows PowerShell cmdlet that resembles the following:
    Get-Mailbox | Set-Mailbox -SingleItemRecoveryEnabled $True -RetainDeletedItemsFor 30
Did this fix the problem?
  • Check whether the problem is fixed.
  • We would appreciate your feedback. To provide feedback or to report any issues with this solution, please leave a comment on the "Fix it for me" blog or send us an email message.

To recover items that were deleted more than 30 days ago

If you want to recover items for a period of more than 30 days, you must use Litigation Hold.

However, be aware that although Deleted Item retention and Litigation Hold are similar, they are not the same thing.

Specifically, Litigation Hold is an option that is inaccessible to the user. For recovery of deleted items that have aged past 30 days, an Exchange Online admin (who is a member of the Discovery Management Role Group) must perform a discovery search to recover the items.

If you want to implement deleted item recovery for a period of more than 30 days, it's best to use a combination of the following options:
  • Extend deleted item recovery to the maximum value of 30 days to reduce the number of Help desk calls.
  • Implement Legal Hold to cover the time frame that you want.
To implement Litigation Hold for a 2-year period (730 Days) for all users, follow these steps:
  1. Connect to Exchange Online by using remote PowerShell. For more info about how to do this, go to the following Microsoft website:
  2. Run a cmdlet that resembles the following:
    Get-Mailbox -RecipientTypeDetails UserMailbox | Set-Mailbox -LitigationHoldEnabled $true -LitigationHoldDuration 730

↑ Back to the top


More information

The cmdlets in this article require that you use Exchange Online PowerShell. For more information, go to the following Microsoft website:�
Single Item Recovery is intended to let users and admins recover items that were accidentally deleted. Litigation Hold is intended to enable message preservation for compliance and eDiscovery purposes.

Before the availability of Litigation Hold, Single Item Recovery was recommended as a method to meet customer demand for longer hold durations. Single Item Recovery has now been superseded by Litigation Hold. Single Item Recovery should no longer be used for this purpose.

For more information about performing discovery search in Office 365, go to the following Microsoft websites:

↑ Back to the top


Still need help? Go to the Office 365 Community website.

↑ Back to the top


Keywords: o365, o365a, o365p, o365m, o365062011, pre-upgrade, o365022013, after, upgrade, kbfixme, kbmsifixme, o365e, KB2714467

↑ Back to the top

Article Info
Article ID : 2714467
Revision : 6
Created on : 5/16/2013
Published on : 5/16/2013
Exists online : False
Views : 353