Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Error message after you run the MOSDAL Support Toolkit: "There is no Web application login URL registered with the Microsoft Office 365 authentication system"


View products that this article applies to.

Problem

After you run the Microsoft Online Services Diagnostics and Logging (MOSDAL) Support Toolkit, the Active Directory Federation Services (AD FS) diagnostics log contains the following error message:

There is no Web application login URL registered with the Microsoft Office 365 authentication system.

Note This log located at \Admin_Applications\SSO_Diagnostic_Tests\ADFSDiagnostic.txt

↑ Back to the top


Cause

This issue may occur if one of the following conditions is true:
  • The ls service endpoint is disabled in the on-premises AD FS Federation service.
  • The ls service endpoint is enabled in the on-premises AD FS Federation service. But the ls service endpoint was disabled the last time that the update-MSOLFederatedDomain cmdlet was run to update your Microsoft cloud service such as Office 365, Windows Azure, or Windows Intune with AD FS configuration data. To detect whether AD FS metadata isn't updated correctly, see the "Cause" section of the following Microsoft Knowledge Base article:
    2647020 "Sorry, but we're having trouble signing you in" and "80041317" or "80043431" error when a federated user tries to sign in to Office 365, Windows Azure, or Windows Intune

↑ Back to the top


Solution

To resolve this issue, use one of the following methods, as appropriate for your situation.

Method 1: Reset the AD FS service endpoints to the default configuration

For information about how to make sure that the AD FS service endpoints are set up to support single sign-on (SSO) authentication, see the following Microsoft Knowledge Base article:
2712957�Sign in to Office 365, Windows Azure, or Windows Intune fails after you change the federation service endpoint

Method 2: Make sure that the AD FS service endpoint configuration is updated to Windows Azure AD

For information about how to make sure that the AD FS service endpoint configuration metadata is updated to the Windows Azure Active Directory (Windows Azure AD) authentication system, see the "How to update the configuration of the Office 365 federated domain" section of the following article:
2647048 How to update or to repair the configuration of the Office 365 federated domain
Still need help? Go to the Office 365 Community website or the Windows Azure Active Directory Forums website.

↑ Back to the top


Keywords: o365, o365a, o365022013, o365062011, o365e, o365m, pre-upgrade, after, upgrade, mosdal4.5, KB2707358

↑ Back to the top

Article Info
Article ID : 2707358
Revision : 16
Created on : 1/14/2014
Published on : 1/14/2014
Exists online : False
Views : 514