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Error message after you run the MOSDAL Support Toolkit: "No WS-Trust Windows endpoint is published in the Metadata Exchange (MEX) document"


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Problem

After you run the Microsoft Online Services Diagnostics and Logging (MOSDAL) Support Toolkit, the Active Directory Federation Services (AD FS) diagnostics log contains the following error message:

No WS-Trust Windows endpoint is published in the Metadata Exchange (MEX) document.

Note The AD FS diagnostics log is located here:
\Admin_Applications\SSO_Diagnostic_Tests\ADFSDiagnostic.txt

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Cause

This issue may occur if the ls�service endpoint is disabled in the on-premises AD FS Federation service.

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Solution

To resolve this issue, make sure that the AD FS service endpoints are set to support SSO authentication. For more information about how to do this, see the following Microsoft Knowledge Base article: �
2712957�SSO authentication to Office 365 fails after you change AD FS service endpoint settings in the AD FS Management Console �
After you update the service endpoints, make sure that the AD FS service endpoint configuration metadata is updated to the Windows Azure Active Directory (Windows Azure AD) authentication system. For more information about how to do this, see the "How to update the configuration of the Office 365 federated domain" section of the following Microsoft Knowledge Base article: �
2647048 How to update or to repair the configuration of the Office 365 federated domain

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More information

Still need help? Go to the Office 365 Community�website or�the�Windows Azure Active Directory Forums website.

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Keywords: o365, mosdal4.5, o365022013, after, upgrade, o365062011, pre-upgrade, o365e, o365m, o365a, KB2707339

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Article Info
Article ID : 2707339
Revision : 10
Created on : 9/30/2013
Published on : 9/30/2013
Exists online : False
Views : 380