Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

BUG: "Assertion Failed" When You Connect to a SQL Server Through TCP/IP


View products that this article applies to.

Symptoms

When you attempt to connect to a SQL Server through TCP/IP on a Windows 98 client, the following error message can occur:

Assertion failed!

Program: C:\WINDOWS\RUNDLL32.EXE
File: ../src/sqlsspi.c
Line: 120

Expression: Count

For information on how your program can cause an assertion failure, see the Visual C++ documentation on asserts

(Press Retry to debug the application - JIT must be enabled)
If you click Ignore, the following error message is displayed:
Connection failed:
SQLState: 'HY001'
SQL Server Error: 0
[Microsoft][ODBC SQL Server Driver]Memory allocation failure
Connection failed:
SQLState: 'HY000'
SQL Server Error: 8
[Microsoft][ODBC SQL Server Driver]Cannot generate SSPI context
NOTE:The first error message can be displayed with a different line number, such as Line 119 or Line 124, depending on the version of the components installed on your computer.

In the first error message, the executable that is listed after "Program" is the name of the application that attempts the connection. The connection is attempted from the ODBC Data Source Administrator in the Control Panel. Other common application names are the Mmc.exe file for the SQL Server Enterprise Manager, and the Isqlw.exe file for the Query Analyzer.

↑ Back to the top


Cause

This problem occurs because the client computer does not have the Client for Microsoft Networks installed.

↑ Back to the top


Resolution

To resolve this problem, install the Client for Microsoft Networks as one of the networking components on the computer. The Client for Microsoft Networks does not have to be the Primary Network Logon.

↑ Back to the top


Status

Microsoft has confirmed that this is a bug in the Microsoft products that are listed at the beginning of this article.

↑ Back to the top


More information

This problem has been reproduced from several clients, including the SQL Server Enterprise Manager, Query Analyzer, and both the Microsoft Open Database Connectivity (ODBC) and the OLE DB client applications.

This problem has not been reproduced on Windows 98 Second Edition.

↑ Back to the top


References

For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
229608 BUG: SQL 7.0 Desktop Edition Install on Windows 98 Causes Assertion Failed File: ..\SRC\SQLSSPI.C Line: 119

↑ Back to the top


Keywords: kbbug, kbdatabase, kbfix, KB267550

↑ Back to the top

Article Info
Article ID : 267550
Revision : 6
Created on : 2/12/2007
Published on : 2/12/2007
Exists online : False
Views : 468