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OFF2000: Applying Sms20o2k.Exe Hotfix Disables Client Functions


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This article was previously published under Q238968

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Symptoms

To view the "Guide to Deploying Office 2000 with Systems Management Server 2.0" Technet document, visit the following Microsoft Web site: This document includes the following information:
Apply the SMS 2.0 hotfix.
Before you install Office 2000, you need to apply the Sms20o2K.exe hotfix that is in the Office 2000 Resource Kit if your version of the Advertised Programs Manager is earlier than 100.1239.003

Applying the SMS 2.0 Hotfix
The Sms20o2K.exe file is necessary if you have a version of Smsapm32 that is earlier than to 100.1239.003. This fix is necessary for accurate status reporting when you install Office 2000 or any other Windows Installer application using SMS 2.0. Installing the hotfix to later versions, might cause problems, so check your version of Smsapm32 first.
If you perform the preceding steps to install the Office 2000 hotfix on a Systems Management Server (SMS) 2.0-based site that has been upgraded to Service Pack 1 or later, file version mismatch problems may cause SMS client component failures.

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Cause

This issue can occur if you apply the Sms20o2K.exe hotfix after you apply any SMS 2.0 Service Pack (SP1 or later). The Sms20o2K.exe hotfix includes a version of the Apasetup.exe file that is earlier than the version of the Apasetup.exe file installed by any SMS 2.0 Service Pack. All SMS 2.0 service packs contain cumulative hotfixes for SMS 2.0, and after any are applied to an SMS 2.0 site, the Sms20o2K.exe hotfix should not be applied.

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Resolution

To resolve this issue, use either of the following methods:

Method 1

Re-apply the latest SMS 2.0 Service Pack to the site server. Note that this work around only takes effect after this propagates to all site systems and clients.

Method 2

  1. Stop the SMS_Executive and SMS_Site_Component_Manager services.
  2. Copy the service pack source\smssetup\inboxes\clicomp.src\smsapm32\compver.ini file to the site server name\SMS\inboxes\clicomp.src\smsapm32 folder, where service pack source is the source of your Service Pack 1 file, and site server name is your site server name.
  3. Copy the service pack source\smssetup\inboxes\clicomp.src\smsapm32\i386\Apasetup.exe file to the site server name\SMS\inboxes\clicomp.src\smsapm32\i386 folder.
  4. Start the SMS_Executive and SMS _Site_Component_Manager services.
  5. Verify all Client Access Point (CAP) servers receive the latest version of the Apasetup.exe file.
  6. Permit clients to update by running the Smsls.bat file automatically during the log on process or manually from the CAP. Clients may also be manually updated by running the Systems Management tool in Control Panel and clicking Update on the Sites tab.

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More information

Client file version mismatch problems may generate the following entries in the Ccim32.log file:
Checking if component "Software Distribution" needs to be 
installed, upgraded or verified (offer index [4])$$
<CCIM32><Fri Aug 06 20:38:06.290 1999><thread=167 (0xA7)>
Component "Software Distribution" needs to be installed
$$<CCIM32><Fri Aug 06 20:38:06.290 1999><thread=167 (0xA7)>
Trying to open IPC connection with APM...
$$<CCIM32><Fri Aug 06 20:38:07.081 1999><thread=167 (0xA7)>
ERROR: Unable to establish a connection with APM - The system cannot find the file
specified.~~ $$<CCIM32><Fri Aug 06 20:38:13.089 1999><thread=167 (0xA7)>
				
NOTE: This error may be repeated for various optional components on the client computer. Client file version mismatch problems may generate the following entries in the Ccim32.log file: Sample from SP1 ccim32.log:
Checking if component "Software Distribution" needs to be installed, upgraded or verified (offer index [4])
Component "Software Distribution" needs to be installed
Trying to open IPC connection with APM...
ERROR: Unable to establish a connection with APM - The system cannot find the file
specified.~~
				
Sample from SP3 ccim32.log
-  Hardware Inventory Agent:  
Checking if component "Hardware Inventory Agent" needs to be installed, upgraded or verified (offer index [5])  
Component "Hardware Inventory Agent" needs to be installed  
Client core file version (from cliver.exe) is 2.00.1493.3010  
Trying to open IPC connection with APM...  
ERROR: Unable to establish a connection with APM - The system cannot find the file specified.  
Warning - Could not process optional component command; retry on next cycle...
				
NOTE: This log may be repeated for various optional client components enabled on the site.

For additional information visit the following Microsoft Web site to view the "Microsoft Office 2000 Resource Kit Journal": For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
239914� OFF2000: SMS Client Functions Disabled After Installing Hotfix from Office Resource Kit CD

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References

Guide to Deploying Office 2000 with Systems Management Server 2.0:

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Keywords: kbprb, kbnetwork, kbenv, kbui, KB238968

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Article Info
Article ID : 238968
Revision : 7
Created on : 9/30/2007
Published on : 9/30/2007
Exists online : False
Views : 366