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OFF2000: Setup Repeatedly Prompts to Restart After Updating Windows Installer


View products that this article applies to.

This article was previously published under Q237741

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Symptoms

When you run Office 2000 Setup, the following error message may appear:
The Windows installer on your system was updated. You need to reboot to complete this update. After your system restarts, rerun setup to continue Microsoft Office 2000 setup.
However, after you restart your computer and re-run Office Setup, you are once again advised to wait for the Windows Installer to be updated and to restart your computer. This occurs every time you run Office Setup.

If you look at the log file for Office Setup, you see text similar to the following:
G:\OFFICE2000_CD1\ADMIN_IMAGE\msi\instmsi.exe .. failed, error = 3

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Cause

You may experience this problem if all of the following are true:
  • You are using a computer running Windows 98.
  • You are running Setup from an Administrative installation on a Novell server.
  • The path to the Administrative installation is using long file names (not 8.3 file names).
This problem occurs whether you are using the Microsoft client for Novell NetWare or the Novell intraNetWare client.

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Workaround

To work around this problem, do either of the following:
  • Change the location of the Office Administrative installation so that it conforms to the 8.3 naming convention. For example, if your Administrative installation is located in the \OFFICE2000PREM_CD1\ADMIN_IMAGE folder on your server, change this location to \OFFPREM\CD1ADMIN. Then re-run Office Setup. -or-

  • If you do not want to rename the folders on your server, please try the following:

    1. Double-click Instmsi.exe in the \Msi folder.
    2. Restart your computer if prompted.
    3. Double-click Data1.msi in the root of the Office Administrative installation.

      NOTE: Do not double-click Setup.exe, or the problem described in the "Symptoms" section of this article will occur.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

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Keywords: kbbug, kbpending, KB237741

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Article Info
Article ID : 237741
Revision : 4
Created on : 1/24/2007
Published on : 1/24/2007
Exists online : False
Views : 472