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FIX: ADO: Unable To Update Memo Field > 64K In Access Database


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Symptoms

An attempt to update a large (64K or greater) memo field in a client-side recordset using the Jet 3.51 OLE DB provider results in one of the following errors:
Errors occurred.
Run-time error '-2147217887(80040e21)':
-or-

Run-time error '-2147217259(80040005)': Data provider or other service returned an E_FAIL status.

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Cause

This problem is caused by a bug in the Microsoft OLE DB Provider for Jet version 3.51.

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Resolution

This problem only occurs when using the Microsoft OLE DB Provider for Jet version 3.51 and client-side recordsets.

This problem does not occur if you use the Microsoft Access ODBC driver or a server-side recordset.

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Status

Microsoft has confirmed this to be a bug in the Microsoft products listed at the beginning of this article.

This bug has been fixed in the Microsoft OLE DB Provider for Jet versions 4.0 and later.

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Keywords: kbado210sp2fix, kbbug, kbfix, kbjet, kbmdacnosweep, KB198532

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Article Info
Article ID : 198532
Revision : 4
Created on : 3/14/2005
Published on : 3/14/2005
Exists online : False
Views : 557