Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

PRB: Jet 3.51 OLE DB Provider Is Not Installed With MDAC 2.1 or Later


View products that this article applies to.

Symptoms

The "3706: ADO could not find the specified provider" error appears when you try to connect to an Access database through the Jet 3.51 OLE DB provider.

↑ Back to the top


Cause

MDAC 2.0 installs version 3.51 of the Jet OLE DB provider. MDAC versions 2.1 through 2.5 install version 4.0 of the Jet OLE DB provider but does not install version 3.51. MDAC 2.1 does not remove or overwrite version 3.51 of the Jet OLE DB provider if it was previously installed.

The Jet OLE DB provider requires the version number of the provider in order to connect to an Access database.

As a result, if your application specifies version 3.51 of the Jet OLE DB provider in the connection string and you install ADO by redistributing MDAC 2.1, you will be unable to connect to your Access database.

↑ Back to the top


Resolution

The simplest workarounds are as follows:
  • Redistribute MDAC 2.0 components prior to or instead of MDAC 2.1 components.

    -or-
  • Change the connection strings in your application to use version 4.0 of the Jet OLE DB provider.

↑ Back to the top


References

For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
240377 Insuring Jet 3.5 Is Installed Correctly (Part I)

↑ Back to the top


Keywords: kbmdacnosweep, kbprb, KB197902

↑ Back to the top

Article Info
Article ID : 197902
Revision : 9
Created on : 3/14/2005
Published on : 3/14/2005
Exists online : False
Views : 408