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Attachments of certain email messages disappear at the client-side when you use an ExOLEDB-based application to change email messages in an Exchange Server 2007 environment


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You use an Exchange OLE DB provider (ExOLEDB) based application to change email messages�in a Microsoft Exchange Server 2007 environment.
  • A user accesses a mailbox that is hosted on an Exchange Server 2007 server by using Microsoft Office Outlook in Cached Exchange mode.

In this scenario, the attachments in some email messages disappear. The email messages disappear even if the Outlook client re-synchronizes with the Exchange Server 2007 server. However, if the user deletes all items of the affected folder from the client side when this problem occurs, and then performs a full synchronization with the Exchange Server 2007 server, the attachments appear.

Note The ExOLEDB-based application is not designed to delete any attachments.

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Cause

This issue occurs because the email messages are changed by the ExOLEDB-based application. Therefore, the Exchange Server 2007 server deletes the attachments in the email messages and then recreates the attachments. If the Outlook client in Cached Exchange Mode synchronizes with the Exchange Server 2007 server before the attachments are recreated, the attachments disappear at the Outlook client side.

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Resolution

To resolve this problem, install the following update rollup:
2279665� Description of Update Rollup 1 for Exchange Server 2007 Service Pack 3

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

More information about ExOLEDB, visit the following Microsoft website:

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Keywords: KB982542, kbsurveynew, kbexpertiseinter, kbhotfixrollup, kbqfe, kbfix

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Article Info
Article ID : 982542
Revision : 2
Created on : 9/9/2010
Published on : 9/9/2010
Exists online : False
Views : 409