Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A smartcard application cannot read information from some smartcards on a computer that is running Windows Vista or Windows Server 2008


View products that this article applies to.

Symptoms

On a computer that is running Windows Vista or Windows Server 2008, you use an application together with a smartcard reader to read information from smartcards. However, the application cannot retrieve information from the smartcards. When this issue occurs, the application does not work correctly. Additionally, the application may stop responding. For example, you may encounter this issue when you use ActivClient.

↑ Back to the top


Cause

This issue occurs because the smartcards return more information to the smartcard application than the smartcard application expects.Typically, a smartcard application calls the SCardTransmit function to send a service request to a smartcard. Then, the smartcard application expects to receive data back from the smartcard. As defined in the Application Protocol Data Unit (APDU) protocol, a Le field is set to indicate the maximum number of data bytes for the response that is returned from the smartcard. However, some smartcards ignore this field. In this situation, the smartcard returns more data than the smartcard application expects. In this situation, the Usbccid.sys driver returns a STATUS_DEVICE_PROTOCOL_ERROR error. This causes the smartcard application not to be able to retrieve information from these smartcards.

↑ Back to the top


Resolution

To resolve this issue, install this hotfix. After you install this hotfix, a larger buffer is allocated for the smartcard application. When the smartcard application calls the SCardTransmit function, the application can read all the information from the smartcards.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Vista Service Pack 2 or Windows Server 2008 SP2 on the computer. For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack
For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
968849 How to obtain the latest service pack for Windows Server 2008

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Vista and Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600 2 . 22xxxWindows Vista and Windows Server 2008SP2LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are very important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Usbccid.sys6.0.6002.2239930,20806-May-201015:14x86
For all supported x64-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Usbccid.sys6.0.6002.2239938,91206-May-201015:30x64
For all supported IA-64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Usbccid.sys6.0.6002.2239989,60006-May-201015:25IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about SCardTransmit Function, visit the following Microsoft Developer Network (MSDN) website:
General information about SCardTransmit Function For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008
File nameUpdate.mum
File versionNot Applicable
File size3,068
Date (UTC)07-May-2010
Time (UTC)05:05
PlatformNot Applicable
File nameX86_usbccid.inf_31bf3856ad364e35_6.0.6002.22399_none_3950811bc2a99e55.manifest
File versionNot Applicable
File size1,674
Date (UTC)07-May-2010
Time (UTC)05:05
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008
File nameAmd64_usbccid.inf_31bf3856ad364e35_6.0.6002.22399_none_956f1c9f7b070f8b.manifest
File versionNot Applicable
File size1,676
Date (UTC)07-May-2010
Time (UTC)05:05
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size3,092
Date (UTC)07-May-2010
Time (UTC)05:05
PlatformNot Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008
File nameIa64_usbccid.inf_31bf3856ad364e35_6.0.6002.22399_none_39522511c2a7a751.manifest
File versionNot Applicable
File size1,675
Date (UTC)07-May-2010
Time (UTC)05:05
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size2,247
Date (UTC)07-May-2010
Time (UTC)05:05
PlatformNot Applicable

↑ Back to the top


Keywords: kbexpertiseadvanced, kbqfe, kbhotfixserver, kbsurveynew, kbautohotfix, kbexpertiseinter, kbbug, kbfix, KB982334

↑ Back to the top

Article Info
Article ID : 982334
Revision : 2
Created on : 6/2/2010
Published on : 6/2/2010
Exists online : False
Views : 417