Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Two users accounts that are logged on to the same computer cannot use Windows Photo Viewer at the same time in Windows 7, Windows Server 2008 R2, Windows Vista, or Windows Server 2008


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows 7, Windows Server 2008 R2, Windows Vista, or Windows Server 2008.
  • You enable the Fast User Switching feature or the Remote Desktop feature on this computer.
  • You directly log on to the computer. Or, you use a Remote Desktop session to log on to the computer.
  • You open an image file by using Windows Photo Viewer on this computer.
  • While you are logged on to the computer, you use another user account to log on to the computer by using the Fast User Switching feature or by using a Remote Desktop session.
  • You try to start Windows Photo Viewer by using this second user account.
In this scenario, you cannot start the Windows Photo Viewer. Additionally, you receive the following error message if you do not have the Administrator privilege:
Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item.
Note This problem does not occur if you use another application to open the image file, such as Microsoft Paint.

↑ Back to the top


Cause

The issue occurs because the Windows Photo Viewer uses the Microsoft COM+ hosting process (Dllhost.exe). This process is configured to allow only one instance of itself to run on each computer.

↑ Back to the top


Resolution

Hotfix information

Note This hotfix is only for Windows 7 and for Windows Server 2008 R2. If you are running Windows Vista or Windows Server 2008, see the "Workaround" section.

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 or Windows Server 2008 R2 on your computer.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Photoviewer.dll6.1.7600.206451,456,12816-Feb-201007:08x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Photoviewer.dll6.1.7600.206451,728,00016-Feb-201007:37x64
Photoviewer.dll6.1.7600.206451,456,12816-Feb-201007:08x86

↑ Back to the top


Workaround

To work around this problem, use one of the following methods.

Method 1

  1. Click Start, type regedit in the Search box, and then click Regedit in the search results.
  2. In Registry Editor, locate the following registry subkey:
    HKEY_CLASSES_ROOT\AppID\{76D0CB12-7604-4048-B83C-1005C7DDC503}
  3. Right-click the RunAs registry entry, and then click Delete.

Method 2

  1. Click Start, type dcomcnfg in the Search box, and then click dcomcnfg.exe in the search results.
  2. In the Component Services window, expand Component Services, expand Computers, and then expand My Computer.
  3. Right-click COM+ Applications, point to View, and then click Status.
  4. Right-click the COM+ application that has an application ID of {76D0CB12-7604-4048-B83C-1005C7DDC503}, and then click Properties.
  5. In the Properties dialog box, click the Identity tab.
  6. On the Identity tab, click the The launching user option, and then click OK.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about the Fast User Switching Compatibility Service, click the following article number to view the article in the Microsoft Knowledge Base:
294855 Description of the Fast User Switching Compatibility Service

For more information about the Fast User Switching feature, visit the following Microsoft Web site:For more information about the Interactive User account, visit the following Microsoft Web site:For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameUpdate.mum
File versionNot applicable
File size1,635
Date (UTC)16-Feb-2010
Time (UTC)15:30
PlatformNot applicable
File nameX86_c76c749764ee75c2445fdfceea66abcb_31bf3856ad364e35_6.1.7600.20645_none_4e01cac8e8cb5db8.manifest
File versionNot applicable
File size699
Date (UTC)16-Feb-2010
Time (UTC)15:30
PlatformNot applicable
File nameX86_microsoft-windows-photoviewer_31bf3856ad364e35_6.1.7600.20645_none_dcc9c1a74a08f8f5.manifest
File versionNot applicable
File size50,296
Date (UTC)16-Feb-2010
Time (UTC)07:37
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_c758ef1a37fd7346bbcb0cc1489d847d_31bf3856ad364e35_6.1.7600.20645_none_358bbd4c4e634088.manifest
File versionNot applicable
File size1,046
Date (UTC)16-Feb-2010
Time (UTC)15:30
PlatformNot applicable
File nameAmd64_microsoft-windows-photoviewer_31bf3856ad364e35_6.1.7600.20645_none_38e85d2b02666a2b.manifest
File versionNot applicable
File size50,300
Date (UTC)16-Feb-2010
Time (UTC)08:13
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size1,850
Date (UTC)16-Feb-2010
Time (UTC)15:30
PlatformNot applicable
File nameX86_microsoft-windows-photoviewer_31bf3856ad364e35_6.1.7600.20645_none_dcc9c1a74a08f8f5.manifest
File versionNot applicable
File size50,296
Date (UTC)16-Feb-2010
Time (UTC)07:37
PlatformNot applicable

↑ Back to the top


Keywords: kb, kbexpertiseadvanced, kbautohotfix, kbfix, kbsurveynew, kbqfe, kbhotfixserver

↑ Back to the top

Article Info
Article ID : 980393
Revision : 1
Created on : 1/7/2017
Published on : 10/6/2011
Exists online : False
Views : 258