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You cannot start a remote application or connect to a remote computer on Forefront Unified Access Gateway


View products that this article applies to.

Symptoms

On a computer that is running Windows Vista or Windows Server 2008, you cannot start a remote application or connect to a remote computer that is hosted on Microsoft Forefront Unified Access Gateway.

For example, you try to start a remote application by creating a browser session to connect to a Unified Access Gateway Web portal. In this case, the connection fails and you receive the following error message:
Your computer cannot connect to the remote computer because the RDG server is temporarily unavailable.


Note This issue also occurs in Windows XP.

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Cause

The Unified Access Gateway server has specialized filters that expect authentication cookies in the HTTP headers. However, the computer that is running Remote Desktop Connection (RDC) does not support this kind of authentication. Therefore, the authentication cookie is unavailable in the HTTP headers. This causes the computer to not connect to the Unified Access Gateway server.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows Vista Service Pack 1 (SP1)
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2 (SP2)
For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack
For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
968849 How to obtain the latest service pack for Windows Server 2008

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Vista and Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600 0 . 20xxxWindows VistaRTMLDR
    6.0.600 1 . 22xxxWindows Vista and Windows Server 2008SP1LDR
    6.0.600 2 . 22xxxWindows Vista and Windows Server 2008SP2LDR
  • Service Pack 1 is integrated into the release version of Windows Server 2008. Therefore, RTM milestone files apply only to Windows Vista. RTM milestone files have a 6.0.0000.xxxxxx version number.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Rpchttp.dll6.0.6001.22608127,48819-Jan-201022:03x86
Rpchttp.dll6.0.6002.22314127,48819-Jan-201022:01x86
For all supported x64-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Rpchttp.dll6.0.6001.22608164,35219-Jan-201022:26x64
Rpchttp.dll6.0.6002.22314164,35219-Jan-201022:05x64
For all supported IA-64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Rpchttp.dll6.0.6001.22608370,68819-Jan-201013:01IA-64
Rpchttp.dll6.0.6002.22314370,68819-Jan-201012:49IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008
File nameX86_80cc6668afdcfb7055a15fe3c2885a15_31bf3856ad364e35_6.0.6001.22608_none_b7ec16598a8e07fb.manifest
File version
File size696
Date (UTC)20-Jan-2010
Time (UTC)06:46
PlatformNot applicable
File nameX86_90e58d110403e66a2d7b670f6d601578_31bf3856ad364e35_6.0.6002.22314_none_c67d957cfd241ee2.manifest
File version
File size696
Date (UTC)20-Jan-2010
Time (UTC)06:46
PlatformNot applicable
File nameX86_microsoft-windows-rpc-http_31bf3856ad364e35_6.0.6001.22608_none_a08a9589586a45f3.manifest
File version
File size7,338
Date (UTC)20-Jan-2010
Time (UTC)00:05
PlatformNot applicable
File nameX86_microsoft-windows-rpc-http_31bf3856ad364e35_6.0.6002.22314_none_a262365d559c51ac.manifest
File version
File size7,338
Date (UTC)20-Jan-2010
Time (UTC)00:02
PlatformNot applicable
Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008
File nameAmd64_1c90c482ae5da271a51b61320adf9e99_31bf3856ad364e35_6.0.6001.22608_none_7ffde6b4bef3687e.manifest
File version
File size1,040
Date (UTC)20-Jan-2010
Time (UTC)06:46
PlatformNot applicable
File nameAmd64_8506de40e0e90d4469f2b8cadb404003_31bf3856ad364e35_6.0.6002.22314_none_a659012ca0f90bd0.manifest
File version
File size1,040
Date (UTC)20-Jan-2010
Time (UTC)06:46
PlatformNot applicable
File nameAmd64_microsoft-windows-rpc-http_31bf3856ad364e35_6.0.6001.22608_none_fca9310d10c7b729.manifest
File version
File size7,368
Date (UTC)20-Jan-2010
Time (UTC)00:21
PlatformNot applicable
File nameAmd64_microsoft-windows-rpc-http_31bf3856ad364e35_6.0.6002.22314_none_fe80d1e10df9c2e2.manifest
File version
File size7,368
Date (UTC)20-Jan-2010
Time (UTC)00:05
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008
File nameIa64_2e3c81b265c32b2e475616a5fc2e9ab4_31bf3856ad364e35_6.0.6001.22608_none_42338bc63c4d3c95.manifest
File version
File size1,038
Date (UTC)20-Jan-2010
Time (UTC)06:46
PlatformNot applicable
File nameIa64_84d685cdaa8f5326691aa2d03945a3cb_31bf3856ad364e35_6.0.6002.22314_none_08c2800b9ad388fd.manifest
File version
File size1,038
Date (UTC)20-Jan-2010
Time (UTC)06:46
PlatformNot applicable
File nameIa64_microsoft-windows-rpc-http_31bf3856ad364e35_6.0.6001.22608_none_a08c397f58684eef.manifest
File version
File size7,351
Date (UTC)20-Jan-2010
Time (UTC)02:44
PlatformNot applicable
File nameIa64_microsoft-windows-rpc-http_31bf3856ad364e35_6.0.6002.22314_none_a263da53559a5aa8.manifest
File version
File size7,351
Date (UTC)20-Jan-2010
Time (UTC)01:10
PlatformNot applicable

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Keywords: kbexpertiseadvanced, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbautohotfix, KB979544

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Article Info
Article ID : 979544
Revision : 1
Created on : 2/8/2010
Published on : 2/8/2010
Exists online : False
Views : 274