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The Exchange Information Store service crashes on a Microsoft Exchange Server 2007 server when a user tries to access a specific calendar item


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Symptoms

The Microsoft Exchange Information Store service crashes on a Microsoft Exchange Server 2007 server when a user tries to access a specific calendar item. Additionally, you find the following error message in the Application log:


Log Name: Application
Source: MSExchange Common
Event ID: 4999
Description:
Watson report about to be sent to dw20.exe for process id: <ID>, with parameters: E12N, c-rtl-AMD64, <version number>, store.exe, EXCHMEM.dll, 49e9, c0000005, <version number>. ErrorReportingEnabled: True

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Cause

This problem occurs because the specific calendar item includes long MIME properties. When the user tries to access the specific calendar item, an Exchange Collaboration Data Objects (ExCDO) background expansion is triggered which causes a heap corruption.

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Resolution

To resolve this problem, install the following update rollup:
979784� Description of Update Rollup 3 for Exchange Server 2007 Service Pack 2

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: KB978528, kbsurveynew, kbexpertiseinter, kbqfe, kbhotfixrollup, kbfix

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Article Info
Article ID : 978528
Revision : 1
Created on : 3/18/2010
Published on : 3/18/2010
Exists online : False
Views : 397