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An invalid value for the elapsed time appears when you use a WDM driver on a computer that is running Windows Vista or Windows Server 2008


View products that this article applies to.

Symptoms

Consider the following scenario:
  • A Windows Driver Model (WDM) driver is used on a computer that is running Windows Server 2008 or Windows Vista. The driver provides a performance counter to report an elapsed time.
  • The driver calculates the elapsed time by querying the data that is returned from the WDM provider.
In this scenario, the counter returns invalid data when you use Performance Monitor to collect the data from this counter.

For example, the expected value is a number. However, the returned value is displayed as the "---" value.

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Cause

The WDM provider provides incorrect data for both the Frequency_PerfTime field and the Timestamp_PerfTime field. This behavior causes the driver to calculate an invalid value for the elapsed time.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows Vista Service Pack 2 (SP2) or Windows Server 2008 Service Pack 2 (SP2).

For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack
For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
968849 How to obtain the latest service pack for Windows Server 2008

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Installation instructions

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows Vista and Windows Server 2008 file information notes


Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both of these operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600 2 . 22xxxWindows Vista and Windows Server 2008SP2LDR
  • Service Pack 1 is integrated into the release version of Windows Server 2008. Therefore, RTM milestone files apply only to Windows Vista. RTM milestone files have a 6.0.0000.xxxxxx version number.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and of Windows Vista

File nameFile versionFile sizeDateTimePlatform
Wmiprov.dll6.0.6002.22276152,57626-Nov-200914:06x86
For all supported x64-based versions of Windows Server 2008 and of Windows Vista

File nameFile versionFile sizeDateTimePlatform
Wmiprov.dll6.0.6002.22276228,35226-Nov-200912:02x64
For all supported IA-64-based versions of Windows Server 2008

File nameFile versionFile sizeDateTimePlatform
Wmiprov.dll6.0.6002.22276481,79226-Nov-200912:02IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about the Windows Driver Model (WDM), visit the following Microsoft Web site: For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008

File nameFile versionFile sizeDateTimePlatform
X86_62be60a76ff0c252076832eb3349543d_31bf3856ad364e35_6.0.6002.22276_none_7715f2e9609bcd57.manifestNot Applicable70427-Nov-200911:33Not Applicable
X86_microsoft-windows-wmi-wdm-provider_31bf3856ad364e35_6.0.6002.22276_none_7c5d34987886f6ab.manifestNot Applicable9,40427-Nov-200900:01Not Applicable
Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008

File nameFile versionFile sizeDateTimePlatform
Amd64_e2fab5784caba3b222b162e91fd38422_31bf3856ad364e35_6.0.6002.22276_none_7d90f138ae76b433.manifestNot Applicable70827-Nov-200911:33Not Applicable
Amd64_microsoft-windows-wmi-wdm-provider_31bf3856ad364e35_6.0.6002.22276_none_d87bd01c30e467e1.manifestNot Applicable9,68826-Nov-200913:30Not Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008

File nameFile versionFile sizeDateTimePlatform
Ia64_d0050597da94fd1dfc4d745843fcdbb4_31bf3856ad364e35_6.0.6002.22276_none_c09a873a9ec7819c.manifestNot Applicable70627-Nov-200911:33Not Applicable
Ia64_microsoft-windows-wmi-wdm-provider_31bf3856ad364e35_6.0.6002.22276_none_7c5ed88e7884ffa7.manifestNot Applicable9,67427-Nov-200910:34Not Applicable

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Keywords: kbqfe, kbhotfixserver, kbsurveynew, kbautohotfix, kbexpertiseadvanced, kbbug, kbfix, KB977926

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Article Info
Article ID : 977926
Revision : 3
Created on : 2/8/2010
Published on : 2/8/2010
Exists online : False
Views : 290