Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You receive an error message when you run certain commands in the EMS on an Exchange Server 2007 server


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Microsoft Exchange Server 2007.
  • You create a parent address list and a child address list in the Exchange Management Console.
  • You change the name of the parent address list.
  • You run one of the following three cmdlets: Set-Mailbox, Set-User, or Set-Mailuser�in the Exchange Management Shell. The target user belongs to the child address list.
In this scenario, you receive an error message. For example, when you run the following cmdlet: �
Set-Mailbox -Identity <user> -<attribute parameter> <attribute value>
You receive the following error message:

Set-Mailbox: Active Directory operation failed on <FQDN of Exchange Server>. This error is not retriable. Additional information: The name reference is invalid.

This may be caused by replication latency between Active Directory domain controllers.

Active directory response: 000020B5: AtrErr: DSID-03152392, #1:

0: 000020B5: DSID-03152392, problem 1005 (CONSTRAINT_ATT_TYPE), data 0, Att

90284 (showInAddressBook)

At line:1 char:12

+ Set-Mailbox <<<< -Identity <user> - <attribute parameter><attribute value>

↑ Back to the top


Cause

This problem occurs because Exchange System Attendant Service captures the change and updates the parent address list when you change the name of the parent address list. However, the child address list is not updated.

↑ Back to the top


Resolution

To resolve this issue, install the following update rollup:
2509911� Description of Update Rollup 4 for Exchange Server 2007 Service Pack 3

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about the Set-Mailbox cmdlet, visit the following Microsoft website:For more information about the Set-User cmdlet, visit the following Microsoft website:For more information about the Set-Mailuser cmdlet, visit the following Microsoft website:

↑ Back to the top


Keywords: KB977906, kbhotfixrollup, kbsurveynew, kbqfe, kbexpertiseinter, kbfix

↑ Back to the top

Article Info
Article ID : 977906
Revision : 2
Created on : 7/7/2011
Published on : 7/7/2011
Exists online : False
Views : 460