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Error message when you install an update by using Windows Update on a computer that is running Windows Vista or Windows Server 2008: "0x80070490"


View products that this article applies to.

Symptoms

Consider the following scenario:
  • Many updates are installed on a computer that is running Windows Server 2008 or Windows Vista.
  • You install an update by using Windows Update.
In this scenario, the update cannot be installed, and you receive the error code 0x80070490.

If you open the following folder on this computer, over 1024 log files can be found in this folder:
%WINDIR%\system32\catroot2
Sometimes, the following event log entry is logged in the Application log:

Source: ESENT
Date: <date>
Event ID: 471
Task Category: Logging/Recovery
Level: Error
Keywords: Classic
User: N/A
Computer: <computer name>
Description: Catalog Database (684) Catalog Database: Unable to rollback operation #252237 on database C:\Windows\system32\CatRoot2\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\catdb. Error: -614. All future database updates will be rejected.

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Cause

The issue occurs because the JetTranaction log space that is used by the catalog database exceeds the 64 MB limitation. Therefore, the catalog database engine can no longer add catalog file entries.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running one of the following Windows operating systems:
  • Windows Vista Service Pack 1 (SP1)
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2 (SP2)
For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack
For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
968849 How to obtain the latest service pack for Windows Server 2008

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Installation instructions

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To use one of the hotfixes that are in this package, you must create the following registry key:
Location: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography\CatalogDB
Name: JET_paramLogFileSize
Type: REG_DWORD
Value: 128 (Decimal)

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Vista and Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both of these operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600 0 . 20xxxWindows VistaRTMLDR
    6.0.600 1 . 22xxxWindows Vista and Windows Server 2008SP1LDR
    6.0.600 2 . 22xxxWindows Vista and Windows Server 2008SP2LDR
  • Service Pack 1 is integrated into the release version of Windows Server 2008. Therefore, RTM milestone files apply only to Windows Vista. RTM milestone files have a 6.0.0000.xxxxxx version number.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and of Windows Vista

File nameFile versionFile sizeDateTimePlatform
Cryptsvc.dll6.0.6001.22570129,53626-Nov-200912:07x86
Cryptsvc.dll6.0.6002.22276130,04826-Nov-200914:00x86
For all supported x64-based versions of Windows Server 2008 and of Windows Vista

File nameFile versionFile sizeDateTimePlatform
Cryptsvc.dll6.0.6001.22570167,42426-Nov-200913:12x64
Cryptsvc.dll6.0.6002.22276168,44826-Nov-200911:58x64
For all supported IA-64-based versions of Windows Server 2008

File nameFile versionFile sizeDateTimePlatform
Cryptsvc.dll6.0.6001.22570342,01626-Nov-200912:09IA-64
Cryptsvc.dll6.0.6002.22276342,01626-Nov-200911:56IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008

File nameFile versionFile sizeDateTimePlatform
Update.mumNot Applicable3,56527-Nov-200912:37Not Applicable
X86_69adb1554c45ef81d69f2e1ad5495aec_31bf3856ad364e35_6.0.6002.22276_none_af64126715de0809.manifestNot Applicable70027-Nov-200912:37Not Applicable
X86_99b4429fd7ada3a69538f42f4627f7b5_31bf3856ad364e35_6.0.6001.22570_none_a5390cbf571713f8.manifestNot Applicable70027-Nov-200912:37Not Applicable
X86_microsoft-windows-cryptsvc-dll_31bf3856ad364e35_6.0.6001.22570_none_763d8e53b425a5e6.manifestNot Applicable7,48926-Nov-200914:02Not Applicable
X86_microsoft-windows-cryptsvc-dll_31bf3856ad364e35_6.0.6002.22276_none_782a01f7b1469314.manifestNot Applicable7,48927-Nov-200900:03Not Applicable
Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008

File nameFile versionFile sizeDateTimePlatform
Ia64_21092d21276ddd833556432aa18c8c56_31bf3856ad364e35_6.0.6001.22570_none_7cd6b6ea049f1281.manifestNot Applicable70227-Nov-200912:37Not Applicable
Ia64_microsoft-windows-cryptsvc-dll_31bf3856ad364e35_6.0.6001.22570_none_763f3249b423aee2.manifestNot Applicable7,50626-Nov-200913:39Not Applicable
Ia64_microsoft-windows-cryptsvc-dll_31bf3856ad364e35_6.0.6002.22276_none_782ba5edb1449c10.manifestNot Applicable7,50627-Nov-200910:36Not Applicable
Update.mumNot Applicable2,74827-Nov-200912:37Not Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008

File nameFile versionFile sizeDateTimePlatform
Amd64_b6abaec5c7bde6c23e66f19d8dbbd01b_31bf3856ad364e35_6.0.6001.22570_none_32e35b5c7ecdbac6.manifestNot Applicable70427-Nov-200912:37Not Applicable
Amd64_d213587dba33787be46f3b53af16bc7c_31bf3856ad364e35_6.0.6002.22276_none_ec65b3f9b260d98a.manifestNot Applicable1,04827-Nov-200912:37Not Applicable
Amd64_microsoft-windows-cryptsvc-dll_31bf3856ad364e35_6.0.6001.22570_none_d25c29d76c83171c.manifestNot Applicable7,52326-Nov-200914:57Not Applicable
Amd64_microsoft-windows-cryptsvc-dll_31bf3856ad364e35_6.0.6002.22276_none_d4489d7b69a4044a.manifestNot Applicable7,52326-Nov-200913:32Not Applicable
Update.mumNot Applicable3,59327-Nov-200912:37Not Applicable

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Keywords: kbqfe, kbhotfixserver, kbsurveynew, kbautohotfix, kbexpertiseinter, kbbug, kbfix, KB977893

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Article Info
Article ID : 977893
Revision : 3
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 738