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Files print in an incorrect order when the collate option is selected, or you receive an error message when you use custom forms: "Faulting application spoolsv.exe"


View products that this article applies to.

Symptoms

This update fixes the following printing issues on a computer that is running Windows Vista or Windows Server 2008.

Issue 1

Consider the following scenario:
  • You try to print a file on a computer that is running Windows Vista or Windows Server 2008.
  • The printer uses the WinPrint print processor.
  • You print one copy of a multiple-page document. 
  • You print multiple copies of a single-page document.
  • You select the Collate option in the Print dialog box.
In this scenario, the output is ordered as if the Collate option is not selected.


Note Printers may have several features that can cause the printed output to contain more pages than the original file. This includes the following features:
  • Add front or back covers
  • Insert pages at specified locations in a print job
  • Insert separator pages
  • Print with a saved job. For example, adding a cover letter to a saved document and printing them together as one job.

Issue 2

Consider the following scenario:
  • You set up a print server failover cluster on a Windows Server 2008-based computer.
  • You install a printer that supports custom forms on the cluster. Custom form support lets you print custom forms such as greeting cards, business cards, and other custom forms.
  • You create a DWORD registry entry that is named AllowUserManageForms under the following subkey:

    HKLM\Cluster\Resources\<PrintSpoolerGUID>\Parameters

    Then you set the registry entry value to 1.
  • In Control Panel, you click Printers, and then you create a custom form in the Print Server Properties dialog box.
  • You set printing preferences on the printer so that the printer can use the custom form.
  • You move the print spooler resource quickly between the two nodes several times.
In this scenario, the print spooler service (Spoolsv.exe) that is called for this print job crashes. Additionally, an error message that resembles the following is logged in the Application log:

Application Error: Event ID 1000

General: Faulting application spoolsv.exe, version 6.0.6002.18005, time stamp 0x49e03626, faulting module ntdll.dll, version 6.0.6002.18005, time stamp 0x49e0421d, exception code 0xc0000005, fault offset <offset>, process id <id>, application start time <start time>.







When this problem occurs, the status of the print spooler resource is displayed as "Online Pending," "Offline Pending," or "Online."

Note You might still receive this error message when the print spooler resource on this node is moved successfully in the Failover Cluster Management snap-in. This behavior occurs because the print spooler service has restarted.

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Cause

This issue occurs because the print spooler service tries to access freed memory. This causes the print spooler service to crash.

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Resolution

A hotfix is available to address the issues listed above.

Note The printer driver must explicitely set the registry key SinglePageKeepCollate per print queue by calling the SetPrinterData API. This value is not set by default.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running one of the following operating systems:
  • Windows Vista Service Pack 1 (SP1)
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2 (SP2)
For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:

935791 How to obtain the latest Windows Vista service pack

For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

968849 How to obtain the latest service pack for Windows Server 2008

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Vista and Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600
    1.
    22xxx
    Windows Vista and Windows Server 2008SP1LDR
    6.0.600
    2.
    22xxx
    Windows Vista and Windows Server 2008SP2LDR
  • Service Pack 1 is integrated into the release version of Windows Server 2008. Therefore, RTM milestone files apply only to Windows Vista. RTM milestone files have a 6.0.0000.xxxxxx version number.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and of Windows Vista

File nameFile versionFile sizeDateTimePlatform
Localspl.dll6.0.6001.22598637,95206-Jan-201017:23x86
Localspl.dll6.0.6002.22303624,12806-Jan-201016:03x86
For all supported x64-based versions of Windows Server 2008 and of Windows Vista

File nameFile versionFile sizeDateTimePlatform
Localspl.dll6.0.6001.22598793,60006-Jan-201016:47x64
Localspl.dll6.0.6002.22303774,65606-Jan-201016:07x64
Localspl.dll6.0.6001.22598637,95206-Jan-201017:23x86
Localspl.dll6.0.6002.22303624,12806-Jan-201016:03x86
For all supported IA-64-based versions of Windows Server 2008

File nameFile versionFile sizeDateTimePlatform
Localspl.dll6.0.6001.225981,625,08806-Jan-201017:07IA-64
Localspl.dll6.0.6002.223031,625,08806-Jan-201015:55IA-64
Localspl.dll6.0.6001.22598637,95206-Jan-201017:23x86
Localspl.dll6.0.6002.22303624,12806-Jan-201016:03x86

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Workaround

To work around issue 2, set the value of the AllowUserManageForms registry entry to 0. This is a global setting that prevents custom forms from being used.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


For more information about the print spooler, visit the following Microsoft Developer Network (MSDN) Web site:

For more information about print management in Windows Server 2008, visit the following MSDN Web site:

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008

File nameFile versionFile sizeDateTimePlatform
X86_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.0.6001.22598_none_304bb562ac0d7372.manifestNot Applicable14,44206-Jan-201019:30Not Applicable
X86_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.0.6002.22303_none_328e770aa8ef4b91.manifestNot Applicable14,42306-Jan-201019:08Not Applicable
Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008

File nameFile versionFile sizeDateTimePlatform
Amd64_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.0.6001.22598_none_8c6a50e6646ae4a8.manifestNot Applicable14,51206-Jan-201019:13Not Applicable
Amd64_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.0.6002.22303_none_8ead128e614cbcc7.manifestNot Applicable14,49306-Jan-201019:08Not Applicable
X86_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.0.6001.22598_none_304bb562ac0d7372.manifestNot Applicable14,44206-Jan-201019:30Not Applicable
X86_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.0.6002.22303_none_328e770aa8ef4b91.manifestNot Applicable14,42306-Jan-201019:08Not Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008

File nameFile versionFile sizeDateTimePlatform
Ia64_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.0.6001.22598_none_304d5958ac0b7c6e.manifestNot Applicable14,45806-Jan-201019:09Not Applicable
Ia64_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.0.6002.22303_none_32901b00a8ed548d.manifestNot Applicable14,45806-Jan-201018:52Not Applicable
Onenote table of contents.onetoc2Not Applicable3,65619-Jan-201006:16Not Applicable
X86_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.0.6001.22598_none_304bb562ac0d7372.manifestNot Applicable14,44206-Jan-201019:30Not Applicable
X86_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.0.6002.22303_none_328e770aa8ef4b91.manifestNot Applicable14,42306-Jan-201019:08Not Applicable

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Keywords: kb, kbqfe, kbhotfixserver, kbsurveynew, kbautohotfix, kbexpertiseinter, kbbug, kbfix

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Article Info
Article ID : 977263
Revision : 1
Created on : 1/7/2017
Published on : 4/7/2011
Exists online : False
Views : 937