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Event ID 2059 is logged after a successful restore on an Exchange 2007 CCR Cluster service


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You are running a Microsoft Exchange Server 2007 Cluster Continuous Replication (CCR) Cluster service
  • You use Symantec NetBackup v6.5.3 or a later version to perform a full system backup
In this scenario, Symantec NetBackup has an optional feature that lets administrators perform a full system backup. This only keeps the uncommitted transaction log files instead of all the log files. If you use this feature to back up a Microsoft Exchange Server 2007 CCR cluster and then you later restore any backup after the first backup, the restore to the active node completes successfully and the database can be mounted. However, an attempt to reseed or resume replication to the passive CCR node subsequently fails and a 2059 event that resembles the following message is logged in the Application log:

Log Name:      Application
Source:        MSExchangeRepl
Date:          28/08/2009 15:45:19
Event ID:      2059
Task Category: Service
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      Exchange2007server.domain.com
Description:
The log file 897 for Exchange2007server\First Storage Group is missing on the production copy. Continuous replication for this storage group is blocked. If you removed the log file, please replace it. If the log is lost, the passive copy will need to be reseeded using the Update-StorageGroupCopy cmdlet in the Exchange Management Shell.
The log file mentioned in the event id 2059 matches the last log in the previous backup set.


If the passive node does not have a copy of the database and the transaction logs, you have to use the Update-StorageGroupCopy command from the Exchange Management Shell or the Exchange Management Console interface to reseed the copy. In the above scenario, the attempt to reseed the passive node fails when it tries to copy the transaction log files to the passive node.

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Cause

When the Microsoft Exchange Replication service determines which transaction log files have to be replicated to the passive node, the Exchange Replication service checks which log files are present on the disk on the active node. Then, the Exchange Replication service compares the log files that have the value of the previous Full Backup Log Gen. If the value of the Previous Full Backup Log Gen is less than the lowest log generation present on the active node, then the 2059 event will be logged and the replication will fail.

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Workaround

You can work around this problem by following one of many variations on the same theme. Two of the many possible variations are:
  • If you complete another full backup after the successful restore, then the database header is updated and the next try to resume or update the replication will succeed.
  • Alternatively you can copy the database and log files manually to the passive node by using windows explorer or another tool, such as Xcopy, before you resume or update storage group copy.
Note The information in this article is only applicable if Symantec NetBackup is used with the option to perform a full system backup and only keeps the uncommitted log files, and you restore the second cluster or a later cluster in the series of backups. If the first backup is used, then these symptoms will not be exhibited. Similarly, if a regular full system backup with all log files is performed, then these symptoms will not be exhibited.

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More information

The database header below is an example of what you would expect to see when this problem occurs. In this particular example the only log file restored was E0000000391.log. Therefore, the lowest log generation on disk was higher than the "Previous Full Backup Log Gen" value of: 897-897 (0x381-0x381) as shown in the following database header:
Initiating FILE DUMP mode...
         Database: Mailbox Database.edb

        File Type: Database
   Format ulMagic: 0x89abcdef
   Engine ulMagic: 0x89abcdef
 Format ulVersion: 0x620,12
 Engine ulVersion: 0x620,12
Created ulVersion: 0x620,12
     DB Signature: Create time:08/13/2009 17:01:41 Rand:2941307 Computer:
         cbDbPage: 8192
           dbtime: 47189 (0xb855)
            State: Dirty Shutdown
     Log Required: 913-913 (0x391-0x391)
    Log Committed: 0-913 (0x0-0x391)
   Streaming File: No
         Shadowed: Yes
       Last Objid: 372
     Scrub Dbtime: 0 (0x0)
       Scrub Date: 00/00/1900 00:00:00
     Repair Count: 0
      Repair Date: 00/00/1900 00:00:00
 Old Repair Count: 0
  Last Consistent: (0x380,8,143)  08/24/2009 10:20:49
      Last Attach: (0x381,9,86)  08/24/2009 10:27:08
      Last Detach: (0x0,0,0)  00/00/1900 00:00:00
             Dbid: 1
    Log Signature: Create time:08/13/2009 17:01:41 Rand:2968206 Computer:
       OS Version: (6.0.6001 SP 1 NLS 500100.50100)

Previous Full Backup:
        Log Gen: 897-897 (0x381-0x381) - OSSnapshot
           Mark: (0x382,B,15E)
           Mark: 08/24/2009 10:26:40

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: KB976592, kbsurveynew, kbtshoot, kbexpertiseinter

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Article Info
Article ID : 976592
Revision : 3
Created on : 10/26/2009
Published on : 10/26/2009
Exists online : False
Views : 361