Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The RemoveDelegate operation of EWS fails, and then a "500 internal server" error response and event ID 4999 are logged in an Exchange Server 2007 server


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Microsoft Exchange Server 2007.
  • You add a delegate to a principal's mailbox by using Microsoft Office Outlook or by using the AddDelegate operation of Exchange Web Services (EWS).
  • You remove the delegate�s mailbox or you delete the delegate�s Active Directory account.
  • You add other delegates to the principal�s mailbox by using the AddDelegate operation of EWS.
  • You try to remove a delegate from the principal's mailbox by using the RemoveDelegate operation of EWS.
In this scenario, you receive a "500 internal server" error from the Exchange Server 2007 server when you call the RemoveDelegate operation of EWS. Additionally, the following event is logged in the Exchange Client Access server�s Application event log:


Log Name: Application
Source: MSExchange Common
Event ID: 4999
Task Category: General
Level: Error
Description:
Watson report about to be sent to dw20.exe for process id: <ID>xxxx, with parameters: E12IIS, buddy-RTL-AMD64, <version number>, WS, M.E.D.Storage, M.E.D.S.Rule.ParticipantFromAdrEntry, System.ArgumentException, <callstackHash>, <version number>. ErrorReportingEnabled: True

↑ Back to the top


Cause

When a delegate's mailbox is deleted from the Exchange Server 2007 organization, the corresponding delegate entry in the properties of the principal's mailbox is not deleted. When you add other delegates by using the AddDelegate operation of EWS, this orphaned delegate entry is converted to NULL. Then, the later RemoveDelegate operation of EWS fails.

↑ Back to the top


Resolution

To fix this problem, install the following update rollup:
972076� Description of Update Rollup 2 for Exchange Server 2007 Service Pack 2

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about EWS, visit the following Microsoft Web site:

↑ Back to the top


Keywords: KB975903, kbhotfixrollup, kbfix, kbqfe, kbsurveynew, kbexpertiseinter

↑ Back to the top

Article Info
Article ID : 975903
Revision : 2
Created on : 1/22/2010
Published on : 1/22/2010
Exists online : False
Views : 253