Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A non-persistent snapshot cleanup operation is aborted by VSS if the VSS hardware provider takes more than three minutes to perform this operation on a computer that is running Windows Server 2008 or Windows Vista


View products that this article applies to.

Symptoms

When the Volume Shadow Copy Service (VSS) hardware provider takes more than three minutes to clean up a non-persistent snapshot set, the operation is aborted by VSS. Therefore, the hardware provider has insufficient time to delete all non-persistent snapshots. When this problem occurs, you may experience one or more of the following symptoms:
  • The hardware provider is in a bad state.

  • The destination LUNs are in an inconsistent state.

  • In the next VSS operations, the provider is vetoed and SCSI errors occur.
  • In Device Manager, an exclamation point (!) is displayed in front of a disk device to state that the disk device does not work correctly.
Note This issue usually occurs if the snapshot set has multiple logical unit number (LUN) devices.


This problem occurs on a computer that is running one of the following operating systems:
  • Windows Server 2008 Service Pack 2 (SP2)
  • Windows Server 2008
  • Windows Vista Service Pack 2 (SP2)
  • Windows Vista Service Pack 1 (SP1)

↑ Back to the top


Cause

This problem occurs because VSS automatically exits when the service is idle for three minutes.

VSS enters an idle state when the VSS hardware provider cleans up the non-persistent snapshots. If the cleanup process is not finished after three minutes, the VSS service exits and does not check whether the hardware providers are still deleting the non-persistent snapshots. Therefore, this problem occurs.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.


Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the “Hotfix Request” page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

Prerequisites

To apply this hotfix, the computer must be running one of the following operating systems:
  • Windows Server 2008 Service Pack 2 (SP2)
  • Windows Server 2008
  • Windows Vista Service Pack 2 (SP2)
  • Windows Vista Service Pack 1 (SP1)
Additionally, you must stop Volume Shadow Copy Service (VSS) before you install this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista and Windows Server 2008 file information note
  • The files that apply to a specific product, SR_Level (RTM,SPn), and service branch (LDR, GDR) can be identified by examining the fileversion numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.6000.16xxxWindows VistaRTMGDR
    6.0.6000.20xxxWindows VistaRTMLDR
    6.0.6001.18xxxWindows Vista and Windows Server 2008SP1GDR
    6.0.6001.22xxxWindows Vista and Windows Server 2008SP1LDR
    6.0.6002.18xxxWindows Vista and Windows Server 2008SP2GDR
    6.0.6002.22xxxWindows Vista and Windows Server 2008SP2LDR
  • Service Pack 1 is integrated into the original release of Windows Server 2008.
  • GDR service branches contain only fixes that are widelyreleased to address widespread, critical issues. LDR service branches containhotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum)that are installed for each environment are listed separately. MUM and MANIFEST files, andthe associated security catalog (.cat) files, are critical to maintaining thestate of the updated component. The security catalog files (attributes notlisted) are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 SP2, of Windows Server 2008, of Windows Vista SP2, and of Windows Vista SP1
File nameFile versionFile sizeDateTimePlatform
Vssvc.exe6.0.6001.225251,056,76817-Sep-200910:10x86
Vssvc.exe6.0.6002.222281,056,76817-Sep-200909:57x86
For all supported x64-based versions of Windows Server 2008 SP2, of Windows Server 2008, of Windows Vista SP2, and of Windows Vista SP1
File nameFile versionFile sizeDateTimePlatform
Vssvc.exe6.0.6001.225251,434,62417-Sep-200910:26x64
Vssvc.exe6.0.6002.222281,434,62417-Sep-200910:08x64
For all supported Itanium-based versions of Windows Server 2008 SP2 and of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Vssvc.exe6.0.6001.225252,440,70417-Sep-200910:11IA-64
Vssvc.exe6.0.6002.222282,440,70417-Sep-200910:05IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Additional file information for Windows Server 2008 SP2, for Windows Server 2008, for Windows Vista SP2, and for Windows Vista SP1

Additional files for all supported x86-based versions of Windows Server 2008 SP2, of Windows Server 2008, of Windows Vista SP2, and of Windows Vista SP1

File nameFile versionFile sizeDateTimePlatform
Package_for_kb975831_client_1~31bf3856ad364e35~x86~~6.0.1.0.mumNot applicable1,36718-Sep-200910:14Not applicable
Package_for_kb975831_client_2~31bf3856ad364e35~x86~~6.0.1.0.mumNot applicable1,69318-Sep-200910:14Not applicable
Package_for_kb975831_client~31bf3856ad364e35~x86~~6.0.1.0.mumNot applicable1,71318-Sep-200910:14Not applicable
Package_for_kb975831_sc_0~31bf3856ad364e35~x86~~6.0.1.0.mumNot applicable1,42118-Sep-200910:14Not applicable
Package_for_kb975831_sc_1~31bf3856ad364e35~x86~~6.0.1.0.mumNot applicable1,69018-Sep-200910:14Not applicable
Package_for_kb975831_sc~31bf3856ad364e35~x86~~6.0.1.0.mumNot applicable1,70118-Sep-200910:14Not applicable
Package_for_kb975831_server_0~31bf3856ad364e35~x86~~6.0.1.0.mumNot applicable1,42518-Sep-200910:14Not applicable
Package_for_kb975831_server_1~31bf3856ad364e35~x86~~6.0.1.0.mumNot applicable1,69418-Sep-200910:14Not applicable
Package_for_kb975831_server~31bf3856ad364e35~x86~~6.0.1.0.mumNot applicable1,71318-Sep-200910:14Not applicable
X86_microsoft-windows-vssservice_31bf3856ad364e35_6.0.6001.22525_none_5b45d4743100bec2.manifestNot applicable33,70017-Sep-200914:21Not applicable
X86_microsoft-windows-vssservice_31bf3856ad364e35_6.0.6002.22228_none_5d2f473a2e245feb.manifestNot applicable33,70017-Sep-200913:51Not applicable

Additional files for all supported x64-based versions of Windows Server 2008 SP2, of Windows Server 2008, of Windows Vista SP2, and of Windows Vista SP1

File nameFile versionFile sizeDateTimePlatform
Amd64_microsoft-windows-vssservice_31bf3856ad364e35_6.0.6001.22525_none_b7646ff7e95e2ff8.manifestNot applicable33,99017-Sep-200914:27Not applicable
Amd64_microsoft-windows-vssservice_31bf3856ad364e35_6.0.6002.22228_none_b94de2bde681d121.manifestNot applicable33,99017-Sep-200913:36Not applicable
Package_for_kb975831_client_1~31bf3856ad364e35~amd64~~6.0.1.0.mumNot applicable1,37518-Sep-200910:15Not applicable
Package_for_kb975831_client_2~31bf3856ad364e35~amd64~~6.0.1.0.mumNot applicable1,70518-Sep-200910:15Not applicable
Package_for_kb975831_client~31bf3856ad364e35~amd64~~6.0.1.0.mumNot applicable1,72318-Sep-200910:15Not applicable
Package_for_kb975831_sc_0~31bf3856ad364e35~amd64~~6.0.1.0.mumNot applicable1,42918-Sep-200910:15Not applicable
Package_for_kb975831_sc_1~31bf3856ad364e35~amd64~~6.0.1.0.mumNot applicable1,70218-Sep-200910:15Not applicable
Package_for_kb975831_sc~31bf3856ad364e35~amd64~~6.0.1.0.mumNot applicable1,71118-Sep-200910:15Not applicable
Package_for_kb975831_server_0~31bf3856ad364e35~amd64~~6.0.1.0.mumNot applicable1,43318-Sep-200910:15Not applicable
Package_for_kb975831_server_1~31bf3856ad364e35~amd64~~6.0.1.0.mumNot applicable1,70618-Sep-200910:15Not applicable
Package_for_kb975831_server~31bf3856ad364e35~amd64~~6.0.1.0.mumNot applicable1,72318-Sep-200910:15Not applicable

Additional files for all supported Itanium-based version of Windows Server 2008 SP2 and of Windows Server 2008

File nameFile versionFile sizeDateTimePlatform
Ia64_microsoft-windows-vssservice_31bf3856ad364e35_6.0.6001.22525_none_5b47786a30fec7be.manifestNot applicable33,97017-Sep-200913:42Not applicable
Ia64_microsoft-windows-vssservice_31bf3856ad364e35_6.0.6002.22228_none_5d30eb302e2268e7.manifestNot applicable33,97017-Sep-200913:25Not applicable
Package_for_kb975831_sc_0~31bf3856ad364e35~ia64~~6.0.1.0.mumNot applicable1,42518-Sep-200910:14Not applicable
Package_for_kb975831_sc_1~31bf3856ad364e35~ia64~~6.0.1.0.mumNot applicable1,52918-Sep-200910:14Not applicable
Package_for_kb975831_sc~31bf3856ad364e35~ia64~~6.0.1.0.mumNot applicable1,70618-Sep-200910:14Not applicable
Package_for_kb975831_server_0~31bf3856ad364e35~ia64~~6.0.1.0.mumNot applicable1,42918-Sep-200910:14Not applicable
Package_for_kb975831_server_1~31bf3856ad364e35~ia64~~6.0.1.0.mumNot applicable1,53318-Sep-200910:14Not applicable
Package_for_kb975831_server~31bf3856ad364e35~ia64~~6.0.1.0.mumNot applicable1,71718-Sep-200910:14Not applicable

↑ Back to the top


References

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

972623 A non-persistent snapshot cleanup operation is aborted by VSS if the VSS hardware provider takes more than three minutes to perform this operation on a computer that is running Windows Server 2003 or Windows XP Professional x64 Edition

↑ Back to the top


Keywords: kb, kbbug, kbfix, kbautohotfix, kbsurveynew, kbqfe, kbhotfixserver

↑ Back to the top

Article Info
Article ID : 975831
Revision : 1
Created on : 1/7/2017
Published on : 10/7/2011
Exists online : False
Views : 275