Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The EdgeTransport.exe process crashes intermittently on an Exchange Server 2007 server


View products that this article applies to.

Symptoms

When the EdgeTransport.exe process crashes intermittently on a Microsoft Exchange Server 2007 server, the following events are logged in the Application log:


Source: MSExchange Common
Event ID: 4999
Task Category: General
Level: Error
Description:
Watson report about to be sent to dw20.exe for process id: <process ID>, with parameters: E12, c-RTL-AMD64, <version number>, edgetransport, M.E.D.Storage, M.E.D.S.VAlarm.get_TimeSpan, System.InvalidCastException, 6816, <version number>. ErrorReportingEnabled: False



Source: MSExchangeTransport
Event ID: 10003
Task Category: PoisonMessage
Level: Error
Description:
The transport process failed during message processing with the following call stack: System.InvalidCastException: Specified cast is not valid. at Microsoft.Exchange.Data.Storage.VAlarm.get_TimeSpan() at Microsoft.Exchange.Data.Storage.VEvent.PromoteReminder() at Microsoft.Exchange.Data.Storage.VEvent.Promote(Item item, ConversionAddressCache addressCache, Boolean suppressBodyPromotion) at Microsoft.Exchange.Data.Storage.VCalendar.Promote(Boolean suppressBodyPromotion) at Microsoft.Exchange.Data.Storage.CalendarDocument.ICalToItem(Stream iCalStream, Item item, InboundAddressCache addressCache, Boolean suppressBodyPromotion, String charsetName, String& errorMessage) at Microsoft.Exchange.Data.Storage.InboundMimeConverter.PromoteCalendarMessage() at Microsoft.Exchange.Data.Storage.InboundMimeConverter.ConvertToItemInternal(MimePromotionFlags promotionFlags) at Microsoft.Exchange.Data.Storage.ConvertUtils.CallCts(Trace tracer, String methodName, String exceptionString, CtsCall ctsCall) at Microsoft.Exchange.Data.Storage.InboundMimeConverter.ConvertToItem(MimePromotionFlags promotionFlags) at Microsoft.Exchange.Data.Storage.ItemConversion.InternalConvertAnyMimeToItem(Item itemOut, EmailMessage messageIn, InboundConversionOptions options, MimePromotionFlags promotionFlags, Boolean isStreamToStream) at Microsoft.Exchange.Data.Storage.ItemConversion.ConvertAnyMimeToItem(Item itemOut, EmailMessage messageIn, InboundConversionOptions options, MimePromotionFlags flags) at Microsoft.Exchange.Data.Storage.ItemConversion.ConvertAnyMimeToItem(Item itemOut, EmailMessage messageIn, InboundConversionOptions options) at Microsoft.Exchange.MailboxTransport.StoreDriver.MailItemDeliver.CopyContentToItem(MailRecipient recipient) at Microsoft.Exchange.MailboxTransport.StoreDriver.MailItemDeliver.<>c__DisplayClass1.<DeliverToRecipient>b__0() at Microsoft.Exchange.MailboxTransport.StoreDriver.StorageExceptionHandler.RunUnderExceptionHandler(IMessageConverter converter, StoreDriverDelegate workerFunction) at Microsoft.Exchange.MailboxTransport.StoreDriver.MailItemDeliver.DeliverToRecipient(MailRecipient recipient) at Microsoft.Exchange.MailboxTransport.StoreDriver.MailItemDeliver.DeliverToRecipients() at Microsoft.Exchange.MailboxTransport.StoreDriver.StoreDriver.DeliverMailItem(NextHopConnection connection, TransportMailItem mailItem) at Microsoft.Exchange.MailboxTransport.StoreDriver.StoreDriver.LocalDeliveryCallback(Object state) at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state) at System.Threading._ThreadPoolWaitCallback.PerformWaitCallbackInternal(_ThreadPoolWaitCallback tpWaitCallBack) at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback(Object state)

↑ Back to the top


Cause

This issue occurs when a Microsoft Exchange Server 2007 server receives a message that contains a certain flag.

↑ Back to the top


Resolution

To resolve this problem, install the following update rollup:
972076� Description of Update Rollup 2 for Exchange Server 2007 Service pack 2

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: KB974775, kbhotfixrollup, kbsurveynew, kbqfe, kbfix, kbexpertiseinter

↑ Back to the top

Article Info
Article ID : 974775
Revision : 1
Created on : 1/22/2010
Published on : 1/22/2010
Exists online : False
Views : 385