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Error message when a user who has View Only Administrator permissions runs commands on an Exchange server that has the Client Access Server (CAS) role installed: "Access is denied"


View products that this article applies to.

Symptoms

Consider the following scenario. In an Exchange Server 2007 environment, you delegate a user. You give the user View Only Administrator permissions. The user then runs one of the following commands on an Exchange server that has the Client Access Server (CAS) role installed:
  • Get-OwaVirtualDirectory
  • get-ActiveSyncVirtualDirectory
  • Get-OabVirtualDirectory
In this scenario, the command fails, and the user receives an "Access is denied" error message that resemble of the following error messages:
Error message 1
Get-OwaVirtualDirectory Get-OwaVirtualDirectory : Unable to create IIS (Internet Information Service) directory entry. Error Message is: Access is denied. . HResult = -2147024891
Error message 2
Get-ActiveSyncVirtualDirectory Get-ActiveSyncVirtualDirectory : Unable to create IIS (Internet Information Service) directory entry. Error Message is: Access is denied. . HResult = -2147024891
Error message 3
Get-OabVirtualDirectory : Unable to create IIS (Internet Information Service) directory entry. Error Message is: Access is denied. . HResult = -2147024891 At line:1 char:23 + Get-OabVirtualDirectory
Additionally, the user cannot view the CAS properties through the Exchange Management Console (EMC).

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Cause

This problem occurs because access to the Metabase in Internet Information Server (IIS) is restricted to the user if the user has no local administrative rights. This restriction prevents the Exchange management functions from finishing and providing the details of the CAS configuration.

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Resolution

To administer CAS servers in Microsoft Exchange 2007, the administrator requires local administrator rights. The local rights provide access to the Metabase on the Exchange server that has the CAS role installed.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: KB973620, kbtshoot, kbexpertiseadvanced, kbsurveynew

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Article Info
Article ID : 973620
Revision : 1
Created on : 9/3/2009
Published on : 9/3/2009
Exists online : False
Views : 265