Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Error message when you save a filter as default in the Exchange Management Console (EMC) and then restart the EMC: "The search filter is invalid"


View products that this article applies to.

Symptoms

In a Microsoft Exchange Server 2007 environment, when you save a filter as default in the Exchange Management Console (EMC) and then restart the EMC, you receive a "The search filter is invalid" error message. Additionally, the default filter does not work. Therefore, you have to remove and then re-create the default filter.

The following is an example of the error message that you receive:
Active Directory Operation failed on <domain controller>. This error is not retriable. Active Directory Response: The search filter is invalid. It was running command �get-recipient �resultsize �1000� �sortby �displayname� � RecipientType �usermailbox� �filter �{serverlegacydn �eq��}�

↑ Back to the top


Cause

The filter is saved with the incorrect syntax.

↑ Back to the top


Resolution

To resolve this problem, install the following update rollup:
971534 Description of Update Rollup 1 for Exchange Server 2007 Service Pack 2

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: KB972426, kbqfe, kbhotfixrollup, kbfix, kbexpertiseinter, kbsurveynew

↑ Back to the top

Article Info
Article ID : 972426
Revision : 1
Created on : 11/19/2009
Published on : 11/19/2009
Exists online : False
Views : 348