Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A .p7b certificate does not import correctly when you try to import it by using the Certificate Import Wizard in MMC on a computer that is running Windows Server 2008 or Windows Vista


View products that this article applies to.

Symptoms

On a computer that is running Windows Server 2008 or Windows Vista, you try to import the .p7b format certificate by using the Certificate Import Wizard in Microsoft Management Console (MMC). However, the certificate does not import correctly. When this issue occurs, you can experience the following symptoms:
  • The imported certificate does not have a private key associated with it.
  • The certificate request object in the Certificate Request store remains.
  • The Certificate Import Wizard completes without displaying any errors.

↑ Back to the top


Cause

This problem occurs because .p7b format certificates are not decoded correctly when you import .p7b format certificates from the Certificate Import Wizard in MMC.

↑ Back to the top


Resolution

To resolve this problem, import the certificate by using the certreq -accept command instead of using the Certificate Import Wizard in MMC.

Example:
certreq -accept Certificate.p7b

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: kbtshoot, kbexpertiseinter, KB971510

↑ Back to the top

Article Info
Article ID : 971510
Revision : 3
Created on : 7/21/2009
Published on : 7/21/2009
Exists online : False
Views : 307