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An appointment is displayed incorrectly as an all-day event if you use a mobile device to synchronize the calendar in Outlook


View products that this article applies to.

Symptoms

Consider the following scenario in a Microsoft Exchange Server 2007 environment:
  1. You log on to a mailbox by using Microsoft Office Outlook and then you click Calendar.
  2. You select Month View for the calendar.
  3. When you double-click to create a new appointment, a new event window appears. By default, this event window has the All day event check box already selected.
  4. You enter a subject, a location, and other information in the event window.
  5. You click the Recurrence, icon and then you set a Recurrence pattern for the event.
  6. In the Appointment time section, you set a duration that is less than one day.
  7. You save and then close the event window.
In this scenario, the appointment is displayed correctly in Office Outlook and in Microsoft Office Outlook Web Access. However, if you use a mobile device to synchronize the calendar by using Exchange ActiveSync, you find that this appointment is displayed as an all-day event. There is no start time or end time defined in Outlook or in Office Outlook Web Access.

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Cause

This problem occurs because the All day event flag is not processed correctly.

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Resolution

To resolve this problem, install the following update rollup:
972076� Description of Update Rollup 2 for Microsoft Exchange Server 2007 Service Pack 2

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Workaround

To work around this problem, click to clear the All day event check box when you create the appointment in Outlook.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: KB970817, kbqfe, kbexpertiseinter, kbfix, kbsurveynew

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Article Info
Article ID : 970817
Revision : 2
Created on : 1/22/2010
Published on : 1/22/2010
Exists online : False
Views : 394