Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The System Attendant (SA) resource is not brought online or offline during a failover in an Exchange 2007 Service Pack 1 cluster environment


View products that this article applies to.

Symptoms

In a Microsoft Exchange 2007 Service Pack 1 (SP1) cluster environment, the System Attendant (SA) resource is not brought online or offline during a failover. When this problem occurs, the following events are logged in the Application log:
Log Name: Application
Source: MSExchangeSA
Event ID: 1031
Task Category: General
Level: Error
Keywords: Classic
Description:
One of the System Attendant's task is blocked. 
Function: ScStopVM 
Log Name: Application
Source: MSExchange Cluster
Event ID: 1020
Task Category: ExRes
Level: Error
Keywords: Classic
Description:
Clustered Mailbox Server: <Server name>
Physical Server: <Server name>
Failed to bring the resource Exchange System Attendant Instance (xxxx) offline due to a timeout.

↑ Back to the top


Cause

When the System Attendant resource goes offline, it tries to shut down any child tasks. One child task tries to contact all Public Folder servers in the top level hierarchy. If there are many public folder servers in the Exchange organization, this procedure takes a long time. Therefore, the SA resource times out. Because of this, the SA resource may stay in the "Offline Pending" state on the failed node of the cluster or it may stay in the "Online Pending" state on the node to which it is failing over.

↑ Back to the top


Resolution

To resolve this problem, install Update Rollup 9 for Exchange 2007 Service Pack 1. For more information about Update Rollup 9 for Exchange Server 2007 Service Pack 1, see the following Exchange Help topic: For more information about how to obtain the latest Exchange service pack or update rollup, see the following Exchange Help topic:

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: KB970277, kbqfe, kbhotfixrollup, kbexpertiseinter, kbsurveynew

↑ Back to the top

Article Info
Article ID : 970277
Revision : 2
Created on : 7/17/2009
Published on : 7/17/2009
Exists online : False
Views : 292