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FIX: The host process of the application crashes when the CounterExists method or the Exists method is called on a multiprocessor computer in IIS 6.0


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have an ASP.NET application or a .NET Framework-based application.
  • The application runs on a multiprocessor computer.
  • The application calls the PerformanceCounterCategory.CounterExists method or the PerformanceCounterCategory.Exists method.
In this scenario, you notice that the host process of your application crashes. At the same time, an event that resembles the following may be logged in the Windows Event log:

Event Type: Information
Event Source: Application Error
Event Category: (100)
Event ID: 1004
Date: <date>
Time: <time>
User: N/A Computer: COMPUTERNAME
Description: Faulting application w3wp.exe, version 6.0.3790.3959, faulting module unknown, version 0.0.0.0, fault address <memory address>.

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Cause

This issue occurs because of an issue in the Aspperf.dll file.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Windows Server 2003 Service Pack 2 (SP2) installed to apply this hotfix.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

x86

File nameFile versionFile sizeDateTimePlatform
Aspperf.dll6.0.3790.442321,50410-Dec-200804:53x86

X64

File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Aspperf.dll6.0.3790.442327,64810-Dec-200802:37x64SP2Not Applicable
Waspperf.dll6.0.3790.442321,50410-Dec-200802:37x86SP2WOW

IA-64

File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Aspperf.dll6.0.3790.442347,10410-Dec-200802:37IA-64SP2Not Applicable
Waspperf.dll6.0.3790.442321,50410-Dec-200802:37x86SP2WOW

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Workaround

To work around this issue, use one of the following methods:
  • Avoid calling the System.Diagnostics.PerformanceCounterCategory.CounterExists method or the System.Diagnostics.PerformanceCounterCategory.Exists method.
  • Call the LoadLibray function on the Aspperf.dll file before you call the CounterExists method. Do not call the FreeLibrary function until the CounterExists method is finished.
  • Delete the following registry key to uninstall the ASP performance counters:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ASP

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

This problem occurs most frequently in a virtualized environment.

For more information about the PerformanceCounterCategory methods, visit the following Microsoft Web site:

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References

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbhotfixserver, kbautohotfix, kbexpertiseinter, kbexpertiseadvanced, kbqfe, kbsurveynew, KB960718

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Article Info
Article ID : 960718
Revision : 1
Created on : 2/2/2009
Published on : 2/2/2009
Exists online : False
Views : 310