Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

When you try to uninstall Exchange Server 2007, the uninstall operation stops responding when it runs the task to remove Exchange files


View products that this article applies to.

Symptoms

You start to uninstall Microsoft Exchange Server 2007 by using the Add or Remove Programs item in Control Panel. When you do this, the following tasks are completed successfully:
  • All server roles are removed.
  • The Exchange organization is removed.
However, the uninstall operation stops responding when it runs the task to remove Exchange files. Although the progress bar indicates that 100 percent of the task is completed, the operation does not continue to the next step.

Additionally, when you open Task Manager, the Powershell.exe process constantly displays 25 percent CPU usage.

↑ Back to the top


Cause

This problem occurs because a custom action invokes the Powershell.exe process but never executes the action.

↑ Back to the top


Resolution

To resolve this problem, open Task Manager, and then end the Powershell.exe process. The Powershell.exe process will restart immediately and then complete the uninstall operation.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about how to completely remove Exchange Server 2007, visit the following Microsoft Web site:

↑ Back to the top


Keywords: KB959959, kbtshoot, kbbug, kbexpertiseadvanced, kbuninstall, kbsurveynew, kbstoprespond, kbfile

↑ Back to the top

Article Info
Article ID : 959959
Revision : 1
Created on : 12/17/2008
Published on : 12/17/2008
Exists online : False
Views : 349