Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The Set-Mailbox command does not change the AutomateProcessing attribute for an Exchange Server 2007 user when a regular user mailbox is converted from a room mailbox


View products that this article applies to.

Symptoms

In a Microsoft Exchange Server 2007 environment, consider the following scenario.
  • You create a room mailbox, and you enable AutoAccept for the room mailbox by running the following command in Exchange Management Shell:
    Set-MailboxCalendarSettings -Identity <alias of the room mailbox> -AutomateProcessing:AutoAccept
  • You convert this room mailbox to a regular user mailbox by running the following command:
    Set-Mailbox -Identity <alias of the room mailbox> -Type Regular
In this scenario, when messages are sent to this converted mailbox, those messages are moved to the "Deleted Items" folder, and a response is sent automatically by the user.

↑ Back to the top


Cause

This problem occurs because the Set-Mailbox command does not fully change the attribute for the user. If you run the Get-MailboxCalendarSettings command against the user, you find that AutomateProcessing attribute is still set to "AutoAccept."

↑ Back to the top


Resolution

To resolve this problem, install Update Rollup 7 for Exchange Server 2007 Service Pack 1.

For more information about Update Rollup 7 for Exchange Server 2007 Service Pack 1, see the following Exchange Help topic: For more information about how to obtain the latest Exchange service pack or update rollup, see the following Exchange Help topic:

↑ Back to the top


More information

For more information about the Set-MailboxCalendarSettings command, visit the following Web site:For more information about the Set-Mailbox command, visit the following Web site:

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: KB959952, kbsurveynew, kbhotfixrollup, kbexpertiseadvanced, kbqfe

↑ Back to the top

Article Info
Article ID : 959952
Revision : 2
Created on : 3/18/2009
Published on : 3/18/2009
Exists online : False
Views : 310