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Your USB audio device does not function correctly, and Device Manager shows a yellow exclamation mark on a computer that is running Windows Vista Service Pack 1 or Windows Server 2008


View products that this article applies to.

Symptoms

You connect a USB audio device to a computer that is running Windows Vista Service Pack 1 (SP1) or Windows Server 2008. However, the audio device does not function correctly. When you examine the audio device in Device Manager, you see a yellow exclamation mark (!) next to the audio device. Additionally, the Device status area displays the following error message:
This device cannot start. (Code 10)
Note This problem does not occur in the original version of Windows Vista.

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Cause

This problem occurs because Windows Vista SP1 and Windows Server 2008 send some commands that are incompatible with certain USB audio devices.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the �Hotfix Request� page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

Prerequisites

To apply this hotfix on a Windows Vista-based computer, you must have Windows Vista SP1 installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack
No prerequisites are required for Windows Server 2008-based computers.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Vista and Windows Server 2008 file information notes

  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers that are listed in the following table.
    VersionProductMilestoneService branch
    6.0.6001.22xxxWindows Vista SP1 and Windows Server 2008 SP1SP1LDR
  • The .manifest files and the .mum files that are installed in each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. These files and their associated .cat (security catalog) files are critical to maintaining the state of the updated component. The .cat files are signed with a Microsoft digital signature. The attributes of these security files are not listed.
For all supported x86-based versions of Windows Server 2008 and Windows Vista
File nameFile versionFile sizeDateTimePlatform
Usbaudio.sys6.0.6001.2225273,08827-Aug-200801:26x86
For all supported x64-based versions of Windows Server 2008 and Windows Vista
File nameFile versionFile sizeDateTimePlatform
Usbaudio.sys6.0.6001.2225298,81627-Aug-200802:03x64
For all supported Itanium-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Usbaudio.sys6.0.6001.22252236,92827-Aug-200801:52IA-64

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Server 2008 and Windows Vista
File namePackage_1_for_kb957080~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,981
Date (UTC)27-Aug-2008
Time (UTC)16:14
File namePackage_2_for_kb957080~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,819
Date (UTC)27-Aug-2008
Time (UTC)16:14
File namePackage_for_kb957080_client_1~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,367
Date (UTC)27-Aug-2008
Time (UTC)16:14
File namePackage_for_kb957080_client~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,430
Date (UTC)27-Aug-2008
Time (UTC)16:14
File namePackage_for_kb957080_server_0~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,425
Date (UTC)27-Aug-2008
Time (UTC)16:14
File namePackage_for_kb957080_server~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,430
Date (UTC)27-Aug-2008
Time (UTC)16:14
File nameX86_wdma_usb.inf_31bf3856ad364e35_6.0.6001.22252_none_6d6d6b4ad01f40b5.manifest
File versionNot Applicable
File size1,881
Date (UTC)27-Aug-2008
Time (UTC)16:17
Additional files for all supported x64-based versions of Windows Server 2008 and Windows Vista
File nameAmd64_wdma_usb.inf_31bf3856ad364e35_6.0.6001.22252_none_c98c06ce887cb1eb.manifest
File versionNot Applicable
File size1,883
Date (UTC)27-Aug-2008
Time (UTC)16:20
File namePackage_1_for_kb957080~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,993
Date (UTC)27-Aug-2008
Time (UTC)16:14
File namePackage_2_for_kb957080~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,829
Date (UTC)27-Aug-2008
Time (UTC)16:14
File namePackage_for_kb957080_client_1~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,375
Date (UTC)27-Aug-2008
Time (UTC)16:14
File namePackage_for_kb957080_client~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,438
Date (UTC)27-Aug-2008
Time (UTC)16:14
File namePackage_for_kb957080_server_0~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,433
Date (UTC)27-Aug-2008
Time (UTC)16:14
File namePackage_for_kb957080_server~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,438
Date (UTC)27-Aug-2008
Time (UTC)16:14
Additional files for all supported Itanium-based versions of Windows Server 2008
File nameIa64_wdma_usb.inf_31bf3856ad364e35_6.0.6001.22252_none_6d6f0f40d01d49b1.manifest
File versionNot Applicable
File size1,882
Date (UTC)27-Aug-2008
Time (UTC)16:14
File namePackage_1_for_kb957080~31bf3856ad364e35~ia64~~6.0.1.0.mum
File versionNot Applicable
File size1,824
Date (UTC)27-Aug-2008
Time (UTC)16:14
File namePackage_for_kb957080_server_0~31bf3856ad364e35~ia64~~6.0.1.0.mum
File versionNot Applicable
File size1,429
Date (UTC)27-Aug-2008
Time (UTC)16:14
File namePackage_for_kb957080_server~31bf3856ad364e35~ia64~~6.0.1.0.mum
File versionNot Applicable
File size1,434
Date (UTC)27-Aug-2008
Time (UTC)16:14

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertisebeginner, kbexpertiseinter, kbbug, kbfix, kbqfe, KB957080

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Article Info
Article ID : 957080
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 405