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You experience issues during the Exchange Online trial period or during an e-mail coexistence period between Exchange Online and Exchange Server 2007


View products that this article applies to.

Microsoft Business Productivity Online Standard Suite

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Symptoms

Consider the following scenario:
  • The e-mail environment in your organization uses the following programs:
    • Microsoft Exchange Online
    • Microsoft Exchange Server 2007
    • Microsoft Office Outlook 2007
  • You have a mailbox in Exchange Online and a mailbox in Exchange Server 2007.
  • You have the same primary Simple Mail Transfer Protocol (SMTP) e-mail address in Exchange Online and in Exchange Server 2007.
In this scenario, you experience the following issues:
  • The AutoDiscover feature that Outlook 2007 uses does not configure Outlook 2007 for the Exchange Online environment.
  • The AutoDiscover feature reverts back to Exchange Server 2007. Additionally, you cannot access e-mail when you use the Outlook 2007 client.
Note These issues usually occur during the Exchange Online trial period or during an e-mail coexistence period between Exchange Online and Exchange Server 2007. When the Exchange Server 2007 mailbox that you use is fully migrated to the Exchange Online environment, the Exchange Server 2007 mailbox is deleted.

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Cause

This issue occurs because the AutoDiscover feature uses your SMTP e-mail address. For example, the AutoDiscover feature uses the someone@example.com e-mail address. If there is an SMTP e-mail address conflict and if your computer is joined to an on-premise Active Directory Domain Services (AD DS) domain, the connection to Exchange Server 2007 receives the highest priority.

Note The AutoDiscover feature is an Exchange Server 2007 feature that automatically connects Outlook 2007 clients together with the correct Exchange e-mail server. Therefore, you do not have to provide any Outlook configuration information.

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Resolution

To resolve this issue, we recommend that you follow these steps:
  1. Do not have mailboxes at the same time in Exchange Online and in Exchange Server 2007. Delete the Exchange Server 2007 mailbox as soon as possible after you migrate Exchange Server 2007 mailbox content to Exchange Online.
  2. During the Exchange Online trial period, do not use the same primary SMTP e-mail address for the Microsoft Online user account and for the Exchange Server 2007 user account.

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Workaround

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756� How to back up and restore the registry in Windows
If you must have mailboxes in Exchange Online and in Exchange Server 2007 at the same time and if you must use the same primary SMTP e-mail address for both mailboxes, follow these steps:
  1. Install Outlook 2007 Service Pack 1 (SP1).
  2. Install the hotfix that is described in the following Microsoft Knowledge Base article:
    948716� Description of the Outlook 2007 hotfix package: February 7, 2008
  3. Modify the registry on each client computer. To do this, follow these steps:
    1. Click Start, click Run, type regedit, and then press ENTER.
    2. In the navigation pane, locate and then click the following registry subkey:
      HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\AutoDiscover
    3. Set the following registry values:
      Value name: PreferLocalXML
      Value type: DWORD
      Value data: 1

      Value name: ExcludeHttpRedirect
      Value type: DWORD
      Value data: 0

      Value name: ExcludeHttpsAutodiscoverDomain
      Value type: DWORD
      Value data: 1

      Value name: ExcludeHttpsRootDomain
      Value type: DWORD
      Value data: 1

      Value name: ExcludeScpLookup
      Value type: DWORD
      Value data: 1

      Value name: ExcludeSrvRecord
      Value type: DWORD
      Value data: 1
      Note To set the registry value, right-click the registry Value name, click Modify, type the Value data in the Value data box, and then click OK.
    4. Exit Registry Editor.
    Note To simplify the operation to modify the registry on each client computer, contact Microsoft Online support to obtain a .reg file. To contact Microsoft Online support, visit the following Microsoft TechNet Web site:
After the Exchange Server 2007 mailbox is migrated to Exchange Online, the Outlook 2007 client will always connect to Exchange Online. If the Exchange Server 2007 mailbox is not deleted, you can use Microsoft Office Outlook Web Access to connect to the Exchange Server 2007 mailbox.

After you delete the Exchange Server 2007 mailbox or if you no longer have an Exchange Online mailbox, return the registry to its original settings. To do this, follow these steps:
  1. Click Start, click Run, type regedit, and then press ENTER.
  2. In the navigation pane, locate and then click the following registry subkey:
    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\AutoDiscover
  3. Set the following registry values:
    Value name: PreferLocalXML
    Value type: DWORD
    Value data: 0

    Value name: ExcludeHttpRedirect
    Value type: DWORD
    Value data: 0

    Value name: ExcludeHttpsAutodiscoverDomain
    Value type: DWORD
    Value data: 0

    Value name: ExcludeHttpsRootDomain
    Value type: DWORD
    Value data: 0

    Value name: ExcludeScpLookup
    Value type: DWORD
    Value data: 0

    Value name: ExcludeSrvLookup
    Value type: DWORD
    Value data: 0

    Value name: ExcludeSrvRecord
    Value type: DWORD
    Value data: 0
  4. Exit Registry Editor.
Note To simplify the operation to return the registry to its original settings, contact Microsoft Online support to obtain a .reg file. To contact Microsoft Online support, visit the following Microsoft TechNet Web site:

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Keywords: KB956955, kbtshoot, kbexpertiseinter

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Article Info
Article ID : 956955
Revision : 7
Created on : 9/22/2008
Published on : 9/22/2008
Exists online : False
Views : 391