Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

When you enroll a certificate on a computer that is running Windows Vista or that is running Windows Server 2008, you are prompted to insert a smart card even though a smart card is already inserted


View products that this article applies to.

Symptoms

When you enroll a certificate on a computer that is running Windows Vista or that is running Windows Server 2008, you are prompted to insert a smart card even though a smart card is already inserted. After you unplug your smart card and then plug it in again, the certificate enrollment process continues successfully.

However, if the smart card and the reader are integrated into one unit, you cannot unplug the smart card. For example, if you use a USB token device as a smart card, the certificate enrollment process does not continue even after you unplug and then plug in the USB token device. Therefore, the certificate enrollment fails.

↑ Back to the top


Cause

The certificate enrollment code detects only whether a smart card is inserted into an existing reader. However, it does not determine whether a new reader is connected. Therefore, if the smart card device integrates a smart card and a reader, the smart card device is not recognized.

↑ Back to the top


Resolution

Hotfix information

Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the “Hotfix Request” page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix on a Windows Vista-based computer, you must have Windows Vista Service Pack 1 installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack
No prerequisites are required for Windows Server 2008-based computers.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Vista and Windows Server 2008 file information notes

  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductMilestoneService branch
    6.0.6001.22xxxWindows Vista SP1 and Windows Server 2008 SP1SP1LDR
  • The .manifest files and the .mum files that are installed in each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. These files and their associated .cat (security catalog) files are critical to maintaining the state of the updated component. The .cat files are signed with a Microsoft digital signature. The attributes of these security files are not listed.
For all supported x86-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Certenrollui.dll6.0.6001.22271633,85620-Sep-200804:00x86
For all supported x64-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Certenrollui.dll6.0.6001.22271810,49620-Sep-200804:18x64
Certenrollui.dll6.0.6001.22271633,85620-Sep-200804:00x86

Additional file information for Windows Server 2008 and for Windows Vista

Additional files for all supported x86-based versions of Windows Server 2008 and of Windows Vista
File namePackage_1_for_kb956544~31bf3856ad364e35~x86~~6.0.2.0.mum
File versionNot Applicable
File size1,962
Date (UTC)22-Sep-2008
Time (UTC)18:38
PlatformNot Applicable
File namePackage_2_for_kb956544~31bf3856ad364e35~x86~~6.0.2.0.mum
File versionNot Applicable
File size1,800
Date (UTC)22-Sep-2008
Time (UTC)18:38
PlatformNot Applicable
File namePackage_for_kb956544_client_1~31bf3856ad364e35~x86~~6.0.2.0.mum
File versionNot Applicable
File size1,367
Date (UTC)22-Sep-2008
Time (UTC)18:38
PlatformNot Applicable
File namePackage_for_kb956544_client~31bf3856ad364e35~x86~~6.0.2.0.mum
File versionNot Applicable
File size1,430
Date (UTC)22-Sep-2008
Time (UTC)18:38
PlatformNot Applicable
File namePackage_for_kb956544_server_0~31bf3856ad364e35~x86~~6.0.2.0.mum
File versionNot Applicable
File size1,425
Date (UTC)22-Sep-2008
Time (UTC)18:38
PlatformNot Applicable
File namePackage_for_kb956544_server~31bf3856ad364e35~x86~~6.0.2.0.mum
File versionNot Applicable
File size1,430
Date (UTC)22-Sep-2008
Time (UTC)18:38
PlatformNot Applicable
File nameX86_0ff6b60f09ade06713955da418b6e5cc_31bf3856ad364e35_6.0.6001.22271_none_c652c5fa50ba54df.manifest
File versionNot Applicable
File size715
Date (UTC)22-Sep-2008
Time (UTC)18:38
PlatformNot Applicable
File nameX86_microsoft-windows-x..ificateenrollmentui_31bf3856ad364e35_6.0.6001.22271_none_2ab03965e21e3fda.manifest
File versionNot Applicable
File size9,590
Date (UTC)20-Sep-2008
Time (UTC)04:35
PlatformNot Applicable
For all supported x64-based versions of Windows Server 2008 and of Windows Vista
File nameAmd64_ae1ad29d2a3d010265c97da1bae976a0_31bf3856ad364e35_6.0.6001.22271_none_99c4c5a87ee99a2b.manifest
File versionNot Applicable
File size1,078
Date (UTC)22-Sep-2008
Time (UTC)18:38
PlatformNot Applicable
File nameAmd64_microsoft-windows-x..ificateenrollmentui_31bf3856ad364e35_6.0.6001.22271_none_86ced4e99a7bb110.manifest
File versionNot Applicable
File size9,634
Date (UTC)20-Sep-2008
Time (UTC)04:48
PlatformNot Applicable
File namePackage_1_for_kb956544~31bf3856ad364e35~amd64~~6.0.2.0.mum
File versionNot Applicable
File size2,207
Date (UTC)22-Sep-2008
Time (UTC)18:38
PlatformNot Applicable
File namePackage_2_for_kb956544~31bf3856ad364e35~amd64~~6.0.2.0.mum
File versionNot Applicable
File size2,043
Date (UTC)22-Sep-2008
Time (UTC)18:38
PlatformNot Applicable
File namePackage_for_kb956544_client_1~31bf3856ad364e35~amd64~~6.0.2.0.mum
File versionNot Applicable
File size1,375
Date (UTC)22-Sep-2008
Time (UTC)18:38
PlatformNot Applicable
File namePackage_for_kb956544_client~31bf3856ad364e35~amd64~~6.0.2.0.mum
File versionNot Applicable
File size1,438
Date (UTC)22-Sep-2008
Time (UTC)18:38
PlatformNot Applicable
File namePackage_for_kb956544_server_0~31bf3856ad364e35~amd64~~6.0.2.0.mum
File versionNot Applicable
File size1,433
Date (UTC)22-Sep-2008
Time (UTC)18:38
PlatformNot Applicable
File namePackage_for_kb956544_server~31bf3856ad364e35~amd64~~6.0.2.0.mum
File versionNot Applicable
File size1,438
Date (UTC)22-Sep-2008
Time (UTC)18:38
PlatformNot Applicable
File nameX 86_microsoft-windows-x..ificateenrollmentui_31bf3856ad364e35_6.0.6001.22271_none_2ab03965e21e3fda.manifest
File versionNot Applicable
File size9,590
Date (UTC)20-Sep-2008
Time (UTC)04:35
PlatformNot Applicable

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbqfe, kbautohotfix, kbexpertiseinter, kbbug, kbfix, KB956544

↑ Back to the top

Article Info
Article ID : 956544
Revision : 3
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 1176